diff options
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis-7.0.12/oe-use-libc-malloc.patch')
-rw-r--r-- | meta-oe/recipes-extended/redis/redis-7.0.12/oe-use-libc-malloc.patch | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis-7.0.12/oe-use-libc-malloc.patch b/meta-oe/recipes-extended/redis/redis-7.0.12/oe-use-libc-malloc.patch new file mode 100644 index 000000000..bf05fc4c5 --- /dev/null +++ b/meta-oe/recipes-extended/redis/redis-7.0.12/oe-use-libc-malloc.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 88da6b19ecd00747769663e913aba5e9569c489d Mon Sep 17 00:00:00 2001 | ||
2 | From: Venture Research <tech@ventureresearch.com> | ||
3 | Date: Wed, 6 Feb 2013 20:51:02 -0600 | ||
4 | Subject: [PATCH] hack to force use of libc malloc | ||
5 | |||
6 | Hack to force libc usage as it seems the option to pass it in has been | ||
7 | removed in favor of magic. | ||
8 | |||
9 | Note that this of course doesn't allow tcmalloc and jemalloc, however | ||
10 | jemalloc wasn't building correctly. | ||
11 | |||
12 | Signed-off-by: Venture Research <tech@ventureresearch.com> | ||
13 | |||
14 | Update to work with 4.0.8 | ||
15 | Signed-off-by: Alistair Francis <alistair.francis@wdc.com> | ||
16 | |||
17 | --- | ||
18 | Upstream-Status: Pending | ||
19 | |||
20 | src/Makefile | 3 ++- | ||
21 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/src/Makefile b/src/Makefile | ||
24 | index 2a0d74d..ddabd44 100644 | ||
25 | --- a/src/Makefile | ||
26 | +++ b/src/Makefile | ||
27 | @@ -13,7 +13,8 @@ | ||
28 | # Just use 'make dep', but this is only needed by developers. | ||
29 | |||
30 | release_hdr := $(shell sh -c './mkreleasehdr.sh') | ||
31 | -uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not') | ||
32 | +# use fake uname option to force use of generic libc | ||
33 | +uname_S := "USE_LIBC_MALLOC" | ||
34 | uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not') | ||
35 | OPTIMIZATION?=-O2 | ||
36 | DEPENDENCY_TARGETS=hiredis linenoise lua hdr_histogram | ||