summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch')
-rw-r--r--meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch b/meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch
new file mode 100644
index 000000000..250fdd0ff
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis-7.0.12/hiredis-use-default-CC-if-it-is-set.patch
@@ -0,0 +1,38 @@
1From 9da2d12c9fabfff4b4460accf887658db89687e4 Mon Sep 17 00:00:00 2001
2From: Venture Research <tech@ventureresearch.com>
3Date: Fri, 8 Feb 2013 17:39:52 -0600
4Subject: [PATCH] hiredis: use default CC if it is set
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Instead of trying to automagically figure out CC, which breaks with OE
10as CC has spaces in it, just skip it if one was already passed in.
11
12Signed-off-by: Venture Research <tech@ventureresearch.com>
13
14Update to work with 4.0.8
15Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
16
17Reworked for 6.0.4
18Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
19
20---
21Upstream-Status: Pending
22
23 deps/hiredis/Makefile | 2 --
24 1 file changed, 2 deletions(-)
25
26diff --git a/deps/hiredis/Makefile b/deps/hiredis/Makefile
27index 7e41c97..54717e3 100644
28--- a/deps/hiredis/Makefile
29+++ b/deps/hiredis/Makefile
30@@ -42,8 +42,6 @@ endef
31 export REDIS_TEST_CONFIG
32
33 # Fallback to gcc when $CC is not in $PATH.
34-CC:=$(shell sh -c 'type $${CC%% *} >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
35-CXX:=$(shell sh -c 'type $${CXX%% *} >/dev/null 2>/dev/null && echo $(CXX) || echo g++')
36 OPTIMIZATION?=-O3
37 WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings -Wno-missing-field-initializers
38 DEBUG_FLAGS?= -g -ggdb