summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit/polkit_0.113.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/polkit/polkit_0.113.bb')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.113.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.113.bb b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
new file mode 100644
index 000000000..29e889615
--- /dev/null
+++ b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
@@ -0,0 +1,45 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd
11
12PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
13 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
14
15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
17# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
18PACKAGECONFIG[consolekit] = ",,,consolekit"
19
20PAM_SRC_URI = "file://polkit-1_pam.patch"
21SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
22 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
23 file://0001-do-not-hardcoded-libdir.patch \
24"
25SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf"
26SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81"
27
28EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection"
29
30PACKAGES =+ "${PN}-examples"
31
32FILES_${PN} += " \
33 ${libdir}/${BPN}-1 \
34 ${datadir}/dbus-1 \
35 ${datadir}/${BPN}-1 \
36"
37FILES_${PN}-dbg += "${libdir}/${BPN}-1/.debug"
38
39FILES_${PN}-examples = "${bindir}/*example*"
40
41USERADD_PACKAGES = "${PN}"
42USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
43
44SYSTEMD_SERVICE_${PN} = "${BPN}.service"
45SYSTEMD_AUTO_ENABLE = "disable"