summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch')
-rw-r--r--meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch b/meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch
new file mode 100644
index 000000000..445f2fbdb
--- /dev/null
+++ b/meta-oe/recipes-extended/polkit/files/meson-build-Support-openembedded-OS-for-PAM-config.patch
@@ -0,0 +1,48 @@
1From 7c89b88f0f81ad220d08d69d212c14c6eeefb647 Mon Sep 17 00:00:00 2001
2From: Yoann Congal <yoann.congal@smile.fr>
3Date: Tue, 3 Sep 2024 12:17:42 +0200
4Subject: [PATCH] meson.build: Support "openembedded" OS for PAM config
5
6In Openembedded, same as Suse/Solaris: PAM files are common-*:
7* PAM_FILE_INCLUDE_AUTH: common-auth
8* PAM_FILE_INCLUDE_ACCOUNT: common-account
9* PAM_FILE_INCLUDE_PASSWORD: common-password
10* PAM_FILE_INCLUDE_SESSION: common-session
11See OE-Core libpam recipe.
12
13NB: This is also the same config as Debian but its not mentioned in the
14code.
15
16Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
17Upstream-Status: Backport [https://github.com/polkit-org/polkit/commit/1d4f7f4d9f3d74fb2649c96faa8677416c1aefc2]
18---
19 meson.build | 2 +-
20 meson_options.txt | 2 +-
21 2 files changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/meson.build b/meson.build
24index 302c189..a55f2d6 100644
25--- a/meson.build
26+++ b/meson.build
27@@ -311,7 +311,7 @@ endif
28
29 pam_include = get_option('pam_include')
30 if pam_include == ''
31- if ['suse', 'solaris'].contains(os_type)
32+ if ['suse', 'solaris', 'openembedded'].contains(os_type)
33 pam_conf = {
34 'PAM_FILE_INCLUDE_AUTH': 'common-auth',
35 'PAM_FILE_INCLUDE_ACCOUNT': 'common-account',
36diff --git a/meson_options.txt b/meson_options.txt
37index c2e4a6c..14d7a50 100644
38--- a/meson_options.txt
39+++ b/meson_options.txt
40@@ -6,7 +6,7 @@ option('polkitd_user', type: 'string', value: 'polkitd', description: 'User for
41 option('polkitd_uid', type: 'string', value: '-', description: 'Fixed UID for user running polkitd (polkitd)')
42
43 option('authfw', type: 'combo', choices: ['pam', 'shadow', 'bsdauth'], value: 'pam', description: 'Authentication framework (pam/shadow)')
44-option('os_type', type: 'combo', choices: ['redhat', 'suse', 'gentoo', 'pardus', 'solaris', 'netbsd', 'lfs', ''], value: '', description: 'distribution or OS')
45+option('os_type', type: 'combo', choices: ['redhat', 'suse', 'gentoo', 'pardus', 'solaris', 'netbsd', 'lfs', 'openembedded', ''], value: '', description: 'distribution or OS')
46
47 option('pam_include', type: 'string', value: '', description: 'pam file to include')
48 option('pam_module_dir', type: 'string', value: '', description: 'directory to install PAM security module')