diff options
Diffstat (limited to 'meta-oe/recipes-extended/openwsman/openwsman_2.7.1.bb')
-rw-r--r-- | meta-oe/recipes-extended/openwsman/openwsman_2.7.1.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.7.1.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.7.1.bb new file mode 100644 index 000000000..7fc5d4218 --- /dev/null +++ b/meta-oe/recipes-extended/openwsman/openwsman_2.7.1.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | SUMMARY = "Opensource Implementation of WS-Management" | ||
2 | DESCRIPTION = "Openwsman is a project intended to provide an open-source \ | ||
3 | implementation of the Web Services Management specipication \ | ||
4 | (WS-Management) and to expose system management information on the \ | ||
5 | Linux operating system using the WS-Management protocol. WS-Management \ | ||
6 | is based on a suite of web services specifications and usage \ | ||
7 | requirements that exposes a set of operations focused on and covers \ | ||
8 | all system management aspects. \ | ||
9 | Openwsman Server and service libraries" | ||
10 | HOMEPAGE = "http://www.openwsman.org/" | ||
11 | SECTION = "Applications/System" | ||
12 | |||
13 | DEPENDS = "curl libxml2 openssl libpam" | ||
14 | |||
15 | inherit features_check | ||
16 | REQUIRED_DISTRO_FEATURES = "pam" | ||
17 | |||
18 | SRCREV = "6cdf3bee50388d8e5f70850322a4df57fd685a5e" | ||
19 | |||
20 | SRC_URI = "git://github.com/Openwsman/openwsman.git;branch=master;protocol=https \ | ||
21 | file://libssl-is-required-if-eventint-supported.patch \ | ||
22 | file://openwsmand.service \ | ||
23 | file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \ | ||
24 | " | ||
25 | |||
26 | S = "${WORKDIR}/git" | ||
27 | |||
28 | LICENSE = "BSD-3-Clause" | ||
29 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba" | ||
30 | |||
31 | inherit systemd cmake pkgconfig python3native perlnative | ||
32 | |||
33 | SYSTEMD_SERVICE:${PN} = "openwsmand.service" | ||
34 | SYSTEMD_AUTO_ENABLE = "disable" | ||
35 | |||
36 | LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}" | ||
37 | |||
38 | EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \ | ||
39 | -DBUILD_LIBCIM=NO \ | ||
40 | -DBUILD_PERL=YES \ | ||
41 | -DBUILD_PYTHON3=YES \ | ||
42 | -DBUILD_PYTHON=NO \ | ||
43 | -DCMAKE_INSTALL_PREFIX=${prefix} \ | ||
44 | -DLIB=${baselib} \ | ||
45 | " | ||
46 | |||
47 | do_configure:prepend() { | ||
48 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
49 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
50 | } | ||
51 | |||
52 | do_install:append() { | ||
53 | install -d ${D}/${sysconfdir}/init.d | ||
54 | install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand | ||
55 | ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand | ||
56 | chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh | ||
57 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
58 | install -d ${D}/${systemd_unitdir}/system | ||
59 | install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system | ||
60 | |||
61 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
62 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
63 | sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
64 | fi | ||
65 | } | ||
66 | |||
67 | FILES:${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \ | ||
68 | ${libdir}/openwsman/authenticators/.debug/ \ | ||
69 | " | ||
70 | |||
71 | INSANE_SKIP:${PN} = "dev-so" | ||
72 | RDEPENDS:${PN} = "ruby" | ||