diff options
Diffstat (limited to 'meta-oe/recipes-extended/libidn')
-rw-r--r-- | meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch | 45 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libidn/libidn_1.36.bb (renamed from meta-oe/recipes-extended/libidn/libidn_1.35.bb) | 8 |
2 files changed, 26 insertions, 27 deletions
diff --git a/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch b/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch index 5adc7d9fd..d5fb8e7c8 100644 --- a/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch +++ b/meta-oe/recipes-extended/libidn/libidn/0001-idn-format-security-warnings.patch | |||
@@ -1,6 +1,3 @@ | |||
1 | From 82f98dcbc429bbe89a9837c533cbcbc02e77c790 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <adraszik@tycoint.com> | ||
3 | Date: Tue, 28 Jun 2016 12:43:31 +0100 | ||
4 | Subject: [PATCH] idn: fix printf() format security warnings | 1 | Subject: [PATCH] idn: fix printf() format security warnings |
5 | MIME-Version: 1.0 | 2 | MIME-Version: 1.0 |
6 | Content-Type: text/plain; charset=UTF-8 | 3 | Content-Type: text/plain; charset=UTF-8 |
@@ -48,35 +45,37 @@ Content-Transfer-Encoding: 8bit | |||
48 | | ^ | 45 | | ^ |
49 | 46 | ||
50 | Signed-off-by: André Draszik <adraszik@tycoint.com> | 47 | Signed-off-by: André Draszik <adraszik@tycoint.com> |
51 | --- | 48 | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> |
49 | |||
52 | Upstream-Status: Pending | 50 | Upstream-Status: Pending |
53 | 51 | ||
52 | --- | ||
54 | src/idn.c | 27 ++++++++++++++------------- | 53 | src/idn.c | 27 ++++++++++++++------------- |
55 | 1 file changed, 14 insertions(+), 13 deletions(-) | 54 | 1 file changed, 14 insertions(+), 13 deletions(-) |
56 | 55 | ||
57 | diff --git a/src/idn.c b/src/idn.c | 56 | diff --git a/src/idn.c b/src/idn.c |
58 | index be1c7d1..68e4291 100644 | 57 | index f2fee11..c6e5caa 100644 |
59 | --- a/src/idn.c | 58 | --- a/src/idn.c |
60 | +++ b/src/idn.c | 59 | +++ b/src/idn.c |
61 | @@ -170,7 +170,7 @@ main (int argc, char *argv[]) | 60 | @@ -169,7 +169,7 @@ main (int argc, char *argv[]) |
62 | (args_info.idna_to_unicode_given ? 1 : 0) + | 61 | (args_info.idna_to_unicode_given ? 1 : 0) + |
63 | (args_info.nfkc_given ? 1 : 0) != 1) | 62 | (args_info.nfkc_given ? 1 : 0) != 1) |
64 | { | 63 | { |
65 | - error (0, 0, _("only one of -s, -e, -d, -a, -u or -n can be specified")); | 64 | - error (0, 0, |
66 | + error (0, 0, "%s", _("only one of -s, -e, -d, -a, -u or -n can be specified")); | 65 | + error (0, 0, "%s", |
66 | _("only one of -s, -e, -d, -a, -u or -n can be specified")); | ||
67 | usage (EXIT_FAILURE); | 67 | usage (EXIT_FAILURE); |
68 | } | 68 | } |
69 | @@ -183,7 +183,7 @@ main (int argc, char *argv[]) | ||
69 | 70 | ||
70 | @@ -185,7 +185,7 @@ main (int argc, char *argv[]) | ||
71 | if (!args_info.quiet_given | 71 | if (!args_info.quiet_given |
72 | && args_info.inputs_num == 0 | 72 | && args_info.inputs_num == 0 && isatty (fileno (stdin))) |
73 | && isatty (fileno (stdin))) | ||
74 | - fprintf (stderr, _("Type each input string on a line by itself, " | 73 | - fprintf (stderr, _("Type each input string on a line by itself, " |
75 | + fprintf (stderr, "%s", _("Type each input string on a line by itself, " | 74 | + fprintf (stderr, "%s", _("Type each input string on a line by itself, " |
76 | "terminated by a newline character.\n")); | 75 | "terminated by a newline character.\n")); |
77 | 76 | ||
78 | do | 77 | do |
79 | @@ -197,7 +197,7 @@ main (int argc, char *argv[]) | 78 | @@ -195,7 +195,7 @@ main (int argc, char *argv[]) |
80 | if (feof (stdin)) | 79 | if (feof (stdin)) |
81 | break; | 80 | break; |
82 | 81 | ||
@@ -85,7 +84,7 @@ index be1c7d1..68e4291 100644 | |||
85 | } | 84 | } |
86 | 85 | ||
87 | if (strlen (line) > 0) | 86 | if (strlen (line) > 0) |
88 | @@ -215,7 +215,7 @@ main (int argc, char *argv[]) | 87 | @@ -213,7 +213,7 @@ main (int argc, char *argv[]) |
89 | if (!q) | 88 | if (!q) |
90 | { | 89 | { |
91 | free (p); | 90 | free (p); |
@@ -94,7 +93,7 @@ index be1c7d1..68e4291 100644 | |||
94 | _("could not convert from UTF-8 to UCS-4")); | 93 | _("could not convert from UTF-8 to UCS-4")); |
95 | } | 94 | } |
96 | 95 | ||
97 | @@ -240,7 +240,7 @@ main (int argc, char *argv[]) | 96 | @@ -238,7 +238,7 @@ main (int argc, char *argv[]) |
98 | if (!q) | 97 | if (!q) |
99 | { | 98 | { |
100 | free (r); | 99 | free (r); |
@@ -103,7 +102,7 @@ index be1c7d1..68e4291 100644 | |||
103 | _("could not convert from UTF-8 to UCS-4")); | 102 | _("could not convert from UTF-8 to UCS-4")); |
104 | } | 103 | } |
105 | 104 | ||
106 | @@ -277,7 +277,7 @@ main (int argc, char *argv[]) | 105 | @@ -275,7 +275,7 @@ main (int argc, char *argv[]) |
107 | q = stringprep_utf8_to_ucs4 (p, -1, &len); | 106 | q = stringprep_utf8_to_ucs4 (p, -1, &len); |
108 | free (p); | 107 | free (p); |
109 | if (!q) | 108 | if (!q) |
@@ -112,7 +111,7 @@ index be1c7d1..68e4291 100644 | |||
112 | _("could not convert from UTF-8 to UCS-4")); | 111 | _("could not convert from UTF-8 to UCS-4")); |
113 | 112 | ||
114 | if (args_info.debug_given) | 113 | if (args_info.debug_given) |
115 | @@ -336,7 +336,7 @@ main (int argc, char *argv[]) | 114 | @@ -334,7 +334,7 @@ main (int argc, char *argv[]) |
116 | r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL); | 115 | r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL); |
117 | free (q); | 116 | free (q); |
118 | if (!r) | 117 | if (!r) |
@@ -121,7 +120,7 @@ index be1c7d1..68e4291 100644 | |||
121 | _("could not convert from UCS-4 to UTF-8")); | 120 | _("could not convert from UCS-4 to UTF-8")); |
122 | 121 | ||
123 | p = stringprep_utf8_to_locale (r); | 122 | p = stringprep_utf8_to_locale (r); |
124 | @@ -360,7 +360,7 @@ main (int argc, char *argv[]) | 123 | @@ -358,7 +358,7 @@ main (int argc, char *argv[]) |
125 | q = stringprep_utf8_to_ucs4 (p, -1, NULL); | 124 | q = stringprep_utf8_to_ucs4 (p, -1, NULL); |
126 | free (p); | 125 | free (p); |
127 | if (!q) | 126 | if (!q) |
@@ -130,7 +129,7 @@ index be1c7d1..68e4291 100644 | |||
130 | _("could not convert from UCS-4 to UTF-8")); | 129 | _("could not convert from UCS-4 to UTF-8")); |
131 | 130 | ||
132 | if (args_info.debug_given) | 131 | if (args_info.debug_given) |
133 | @@ -438,7 +438,7 @@ main (int argc, char *argv[]) | 132 | @@ -436,7 +436,7 @@ main (int argc, char *argv[]) |
134 | if (!q) | 133 | if (!q) |
135 | { | 134 | { |
136 | free (p); | 135 | free (p); |
@@ -139,7 +138,7 @@ index be1c7d1..68e4291 100644 | |||
139 | _("could not convert from UCS-4 to UTF-8")); | 138 | _("could not convert from UCS-4 to UTF-8")); |
140 | } | 139 | } |
141 | 140 | ||
142 | @@ -494,7 +494,7 @@ main (int argc, char *argv[]) | 141 | @@ -492,7 +492,7 @@ main (int argc, char *argv[]) |
143 | r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL); | 142 | r = stringprep_ucs4_to_utf8 (q, -1, NULL, NULL); |
144 | free (q); | 143 | free (q); |
145 | if (!r) | 144 | if (!r) |
@@ -148,7 +147,7 @@ index be1c7d1..68e4291 100644 | |||
148 | _("could not convert from UTF-8 to UCS-4")); | 147 | _("could not convert from UTF-8 to UCS-4")); |
149 | 148 | ||
150 | p = stringprep_utf8_to_locale (r); | 149 | p = stringprep_utf8_to_locale (r); |
151 | @@ -523,7 +523,7 @@ main (int argc, char *argv[]) | 150 | @@ -521,7 +521,7 @@ main (int argc, char *argv[]) |
152 | if (!q) | 151 | if (!q) |
153 | { | 152 | { |
154 | free (p); | 153 | free (p); |
@@ -157,7 +156,7 @@ index be1c7d1..68e4291 100644 | |||
157 | _("could not convert from UTF-8 to UCS-4")); | 156 | _("could not convert from UTF-8 to UCS-4")); |
158 | } | 157 | } |
159 | 158 | ||
160 | @@ -537,7 +537,8 @@ main (int argc, char *argv[]) | 159 | @@ -535,7 +535,8 @@ main (int argc, char *argv[]) |
161 | r = stringprep_utf8_nfkc_normalize (p, -1); | 160 | r = stringprep_utf8_nfkc_normalize (p, -1); |
162 | free (p); | 161 | free (p); |
163 | if (!r) | 162 | if (!r) |
@@ -167,7 +166,7 @@ index be1c7d1..68e4291 100644 | |||
167 | 166 | ||
168 | if (args_info.debug_given) | 167 | if (args_info.debug_given) |
169 | { | 168 | { |
170 | @@ -547,7 +548,7 @@ main (int argc, char *argv[]) | 169 | @@ -545,7 +546,7 @@ main (int argc, char *argv[]) |
171 | if (!q) | 170 | if (!q) |
172 | { | 171 | { |
173 | free (r); | 172 | free (r); |
@@ -177,5 +176,5 @@ index be1c7d1..68e4291 100644 | |||
177 | } | 176 | } |
178 | 177 | ||
179 | -- | 178 | -- |
180 | 2.8.1 | 179 | 2.25.1 |
181 | 180 | ||
diff --git a/meta-oe/recipes-extended/libidn/libidn_1.35.bb b/meta-oe/recipes-extended/libidn/libidn_1.36.bb index 105740354..4c6c8fde4 100644 --- a/meta-oe/recipes-extended/libidn/libidn_1.35.bb +++ b/meta-oe/recipes-extended/libidn/libidn_1.36.bb | |||
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=df4be47940a91ee69556f5f71eed4aec \ | |||
8 | file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | 8 | file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
9 | file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 9 | file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
10 | file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \ | 10 | file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \ |
11 | file://lib/idna.h;endline=21;md5=37cffad24807f446a24de3e7371f20b9 \ | 11 | file://lib/idna.h;endline=21;md5=c381d797e2d7fbdace7c147b1285d076 \ |
12 | file://src/idn.c;endline=20;md5=09e97034a8877b3451cb65065fc2c06e" | 12 | file://src/idn.c;endline=20;md5=7d88aa87b0494d690bdf7748fe08d536" |
13 | DEPENDS = "virtual/libiconv autoconf-archive" | 13 | DEPENDS = "virtual/libiconv autoconf-archive" |
14 | 14 | ||
15 | inherit pkgconfig autotools gettext texinfo gtk-doc | 15 | inherit pkgconfig autotools gettext texinfo gtk-doc |
@@ -19,8 +19,8 @@ SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \ | |||
19 | file://0001-idn-format-security-warnings.patch \ | 19 | file://0001-idn-format-security-warnings.patch \ |
20 | " | 20 | " |
21 | 21 | ||
22 | SRC_URI[md5sum] = "bef634141fe39326cb354b75e891fead" | 22 | SRC_URI[md5sum] = "813c7b268d1051ca02c3610986126f38" |
23 | SRC_URI[sha256sum] = "f11af1005b46b7b15d057d7f107315a1ad46935c7fcdf243c16e46ec14f0fe1e" | 23 | SRC_URI[sha256sum] = "14b67108344d81ba844631640df77c9071d9fb0659b080326ff5424e86b14038" |
24 | 24 | ||
25 | # command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3 | 25 | # command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3 |
26 | # so package command into a separate package | 26 | # so package command into a separate package |