summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcec/libcec_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libcec/libcec_git.bb')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index cb65caad8..4ad49971a 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -4,24 +4,30 @@ HOMEPAGE = "http://libcec.pulse-eight.com/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
6 6
7DEPENDS = "p8platform udev lockdev ncurses swig-native python3" 7DEPENDS = "p8platform udev ncurses swig-native python3"
8 8
9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" 9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" 10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
11 11
12PV = "4.0.1+gitr${SRCPV}" 12PV = "4.0.2+gitr${SRCPV}"
13 13
14SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df" 14SRCREV = "0a97062dd4b196ceeb003ec41841c7a7edc36dd1"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \ 15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
16 file://python-install-location.patch" 16 file://0001-Explicitly-use-python3-in-pyCecClient.patch"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit cmake pkgconfig 20inherit cmake pkgconfig
21 21
22# Put client tools into a separate package
23PACKAGE_BEFORE_PN += "${PN}-tools"
24FILES_${PN}-tools = "${bindir}"
25RDEPENDS_${PN}-tools = "python3-${BPN}"
26
22# Create the wrapper for python3 27# Create the wrapper for python3
23PACKAGES += "python3-${BPN}" 28PACKAGES += "python3-${BPN}"
24FILES_python3-${BPN} = "${libdir}/python3*" 29FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
30RDEPENDS_${PN} = "python3-core"
25 31
26# cec-client and xbmc need the .so present to work :( 32# cec-client and xbmc need the .so present to work :(
27FILES_${PN} += "${libdir}/*.so" 33FILES_${PN} += "${libdir}/*.so"