summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch')
-rw-r--r--meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch b/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch
new file mode 100644
index 000000000..8129c1e2a
--- /dev/null
+++ b/meta-oe/recipes-extended/libblockdev/files/0001-libext2fs-unused-parameters-fix.patch
@@ -0,0 +1,92 @@
1From 3aad8d471201da4125bd03d7a6921707461fe182 Mon Sep 17 00:00:00 2001
2From: Vojtech Trefny <vtrefny@redhat.com>
3Date: Fri, 7 Jun 2024 10:06:22 +0200
4Subject: [PATCH 1/3] fs: Ignore unused-parameter warning in the FS plugin
5
6There are some unused parameters in the libext2fs header which
7together with Wall and Werror means the plugin compilation fails.
8As a workaround we'll disable the unused-parameter warning for
9now.
10
11Fixes: #1026
12
13Taken from Fedora
14
15Upstream-Status: Pending
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17
18---
19 src/plugins/fs/Makefile.am | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
23index 7d4849c0..00474d5a 100644
24--- a/src/plugins/fs/Makefile.am
25+++ b/src/plugins/fs/Makefile.am
26@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
27
28 lib_LTLIBRARIES = libbd_fs.la
29
30-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror
31+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter
32 libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
33 libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
34 libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
35--
362.45.2
37
38
39From da5c14f3e2f83c8c40203897154ee2b788782792 Mon Sep 17 00:00:00 2001
40From: Vojtech Trefny <vtrefny@redhat.com>
41Date: Fri, 7 Jun 2024 15:21:09 +0200
42Subject: [PATCH 2/3] fs: Ignore shift-count-overflow warning in FS plugin
43
44The warning happens in the libext2fs header.
45---
46 src/plugins/fs/Makefile.am | 2 +-
47 1 file changed, 1 insertion(+), 1 deletion(-)
48
49diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
50index 00474d5a..42e1c777 100644
51--- a/src/plugins/fs/Makefile.am
52+++ b/src/plugins/fs/Makefile.am
53@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
54
55 lib_LTLIBRARIES = libbd_fs.la
56
57-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter
58+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow
59 libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
60 libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
61 libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
62--
632.45.2
64
65
66From 90ceb4b52fbda34673fe5303da84b9a902187503 Mon Sep 17 00:00:00 2001
67From: Vojtech Trefny <vtrefny@redhat.com>
68Date: Wed, 12 Jun 2024 15:34:02 +0200
69Subject: [PATCH 3/3] fs: Fix ignoring errors from libext2fs
70
71Follow-up for #1028, we still want to show the warning and not
72completely supress it.
73---
74 src/plugins/fs/Makefile.am | 2 +-
75 1 file changed, 1 insertion(+), 1 deletion(-)
76
77diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
78index 42e1c777..1ee256f0 100644
79--- a/src/plugins/fs/Makefile.am
80+++ b/src/plugins/fs/Makefile.am
81@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
82
83 lib_LTLIBRARIES = libbd_fs.la
84
85-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow
86+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-error=unused-parameter -Wno-error=shift-count-overflow
87 libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
88 libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
89 libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
90--
912.45.2
92