summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb
new file mode 100644
index 000000000..8d756e6a4
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Fast data collector for Embedded Linux"
2HOMEPAGE = "http://fluentbit.io"
3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4
5SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \
6 file://0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch \
7 file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \
8 "
9SRC_URI[md5sum] = "9383262339412782b80cc49e7ad15609"
10SRC_URI[sha256sum] = "eb8a85c656fa60682b0bf8dd1ad58d848cd251dab4f35a6777acd552c65b0511"
11
12S = "${WORKDIR}/fluent-bit-${PV}"
13
14LICENSE = "Apache-2.0"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
16
17DEPENDS = "zlib"
18INSANE_SKIP_${PN}-dev += "dev-elf"
19
20inherit cmake systemd
21
22EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS}"
23
24SYSTEMD_SERVICE_${PN} = "fluent-bit.service"