summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
new file mode 100644
index 000000000..8fe9f3e70
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
@@ -0,0 +1,18 @@
1Use CMAKE_INSTALL_LIBDIR instead of hardcoding lib path
2
3Helps build on platforms where libpaths are not lib/ but say lib64/
4
5Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8--- a/src/CMakeLists.txt
9+++ b/src/CMakeLists.txt
10@@ -182,7 +182,7 @@ if(NOT FLB_WITHOUT_SHARED_LIB)
11 PROPERTIES OUTPUT_NAME fluent-bit)
12
13 # Library install routines
14- install(TARGETS fluent-bit-shared LIBRARY DESTINATION lib)
15+ install(TARGETS fluent-bit-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
16 endif()
17
18 # Static Library