diff options
Diffstat (limited to 'meta-oe/recipes-extended/efivar')
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar/0003-efivar-fix-for-cross-compile.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar_0.23.bb | 3 |
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar/0003-efivar-fix-for-cross-compile.patch b/meta-oe/recipes-extended/efivar/efivar/0003-efivar-fix-for-cross-compile.patch new file mode 100644 index 000000000..3f43f2a93 --- /dev/null +++ b/meta-oe/recipes-extended/efivar/efivar/0003-efivar-fix-for-cross-compile.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 7ead29ca6bb5e280ae07551cc3521281ecf73682 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Sat, 7 May 2016 02:06:47 -0400 | ||
4 | Subject: [PATCH] Makefile: fix efivar.pc not found | ||
5 | |||
6 | It fixes efivar.pc not found: | ||
7 | ... | ||
8 | | install -d -m 755 efivar/0.23-r0/image/usr/lib/pkgconfig/ | ||
9 | | install -m 644 efivar.pc efivar/0.23-r0/image/usr/lib/pkgconfig/ | ||
10 | ; install -m 644 efiboot.pc efivar/0.23-r0/image/usr/lib/pkgconfig/ | ||
11 | ; | ||
12 | | install: cannot stat 'efivar.pc': No such file or directory | ||
13 | | install: cannot stat 'efiboot.pc': No such file or directory | ||
14 | | make[1]: *** [install] Error 1 | ||
15 | | make[1]: Leaving directory `efivar/0.23-r0/git/src' | ||
16 | | make: *** [install] Error 2 | ||
17 | | ERROR: oe_runmake failed | ||
18 | ... | ||
19 | |||
20 | Upstream-Status: Pending | ||
21 | |||
22 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
23 | --- | ||
24 | src/Makefile | 4 +++- | ||
25 | 1 file changed, 3 insertions(+), 1 deletion(-) | ||
26 | |||
27 | diff --git a/src/Makefile b/src/Makefile | ||
28 | index c7a0ca3..ad9c427 100644 | ||
29 | --- a/src/Makefile | ||
30 | +++ b/src/Makefile | ||
31 | @@ -78,7 +78,9 @@ install : all | ||
32 | ln -fs $(x).$(VERSION) $(DESTDIR)$(libdir)/$(x).$(MAJOR_VERSION);\ | ||
33 | ln -fs $(x).$(VERSION) $(DESTDIR)$(libdir)/$(x); ) | ||
34 | $(INSTALL) -d -m 755 $(DESTDIR)$(PCDIR) | ||
35 | - $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(x) $(DESTDIR)$(PCDIR) ;) | ||
36 | + $(foreach x, $(PCTARGETS), $(INSTALL) -m 644 $(TOPDIR)/src/$(x).in $(DESTDIR)$(PCDIR)/$(x) ;\ | ||
37 | + sed -i -e "s:@@LIBDIR@@:$(libdir):g" -e "s:@@VERSION@@:$(VERSION):g" \ | ||
38 | + $(DESTDIR)$(PCDIR)/$(x); ) | ||
39 | $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/efivar | ||
40 | $(foreach x, $(wildcard $(TOPDIR)/src/include/efivar/*.h), $(INSTALL) -m 644 $(x) $(DESTDIR)$(includedir)/efivar/$(notdir $(x));) | ||
41 | $(INSTALL) -d -m 755 $(DESTDIR)$(bindir) | ||
42 | -- | ||
43 | 2.8.1 | ||
44 | |||
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.23.bb b/meta-oe/recipes-extended/efivar/efivar_0.23.bb index b41be0335..9c474612a 100644 --- a/meta-oe/recipes-extended/efivar/efivar_0.23.bb +++ b/meta-oe/recipes-extended/efivar/efivar_0.23.bb | |||
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" | |||
7 | 7 | ||
8 | DEPENDS_class-target = "popt efivar-native" | 8 | DEPENDS_class-target = "popt efivar-native" |
9 | 9 | ||
10 | SRCREV = "01abee43d6d6e755f56a4135ab5aa0bfad609ce2" | 10 | SRCREV = "7367d78281fa3ce390e10c7c9f4608c58e7a6d3d" |
11 | SRC_URI = "git://github.com/rhinstaller/efivar.git" | 11 | SRC_URI = "git://github.com/rhinstaller/efivar.git" |
12 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ | 12 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ |
13 | file://0002-disable-static-build.patch \ | 13 | file://0002-disable-static-build.patch \ |
14 | file://0003-efivar-fix-for-cross-compile.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |