summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/dlt-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/dlt-daemon')
-rw-r--r--meta-oe/recipes-extended/dlt-daemon/dlt-daemon/544.patch80
-rw-r--r--meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.10.bb3
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/544.patch b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/544.patch
new file mode 100644
index 000000000..550493351
--- /dev/null
+++ b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/544.patch
@@ -0,0 +1,80 @@
1Upstream-Status: Submitted [https://github.com/COVESA/dlt-daemon/pull/544]
2
3From 5db28a4b85cf0ec3e128cfc7c9b71d12ec543695 Mon Sep 17 00:00:00 2001
4From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
5Date: Thu, 28 Sep 2023 12:54:23 +0200
6Subject: [PATCH] Add common dlt_cdh_cpuinfo.c to unblock build on non amd64
7 and i386 arcs
8
9---
10 src/core_dump_handler/dlt_cdh.h | 2 ++
11 src/core_dump_handler/dlt_cdh_cpuinfo.c | 33 +++++++++++++++++++++++++
12 src/core_dump_handler/dlt_cdh_crashid.c | 2 +-
13 3 files changed, 36 insertions(+), 1 deletion(-)
14 create mode 100644 src/core_dump_handler/dlt_cdh_cpuinfo.c
15
16diff --git a/src/core_dump_handler/dlt_cdh.h b/src/core_dump_handler/dlt_cdh.h
17index d572ecf3..8608c6c4 100644
18--- a/src/core_dump_handler/dlt_cdh.h
19+++ b/src/core_dump_handler/dlt_cdh.h
20@@ -55,6 +55,8 @@ typedef struct
21 uint64_t pc;
22 uint64_t ip;
23 uint64_t lr;
24+ uint64_t sp;
25+ uint64_t fp;
26
27 } cdh_registers_t;
28
29diff --git a/src/core_dump_handler/dlt_cdh_cpuinfo.c b/src/core_dump_handler/dlt_cdh_cpuinfo.c
30new file mode 100644
31index 00000000..d6fc3905
32--- /dev/null
33+++ b/src/core_dump_handler/dlt_cdh_cpuinfo.c
34@@ -0,0 +1,33 @@
35+/*
36+ * SPDX license identifier: MPL-2.0
37+ *
38+ * Copyright (C) 2011-2015, BMW AG
39+ *
40+ * This file is part of COVESA Project DLT - Diagnostic Log and Trace.
41+ *
42+ * This Source Code Form is subject to the terms of the
43+ * Mozilla Public License (MPL), v. 2.0.
44+ * If a copy of the MPL was not distributed with this file,
45+ * You can obtain one at http://mozilla.org/MPL/2.0/.
46+ *
47+ * For further information see http://www.covesa.org/.
48+ */
49+
50+/*!
51+ * \author Gianfranco Costamagna <locutusofborg@debian.org>
52+ *
53+ * \copyright Copyright © 2011-2015 BMW AG. \n
54+ * License MPL-2.0: Mozilla Public License version 2.0 http://mozilla.org/MPL/2.0/.
55+ *
56+ * \file dlt_cdh_cpuinfo.c
57+ */
58+
59+#include "dlt_cdh_cpuinfo.h"
60+
61+void get_registers(prstatus_t *prstatus, cdh_registers_t *registers)
62+{
63+/* struct user_regs_struct *ptr_reg = (struct user_regs_struct *)prstatus->pr_reg;
64+
65+ registers->pc = ptr_reg->pc; /* [REG_PROC_COUNTER]; */
66+*/
67+}
68diff --git a/src/core_dump_handler/dlt_cdh_crashid.c b/src/core_dump_handler/dlt_cdh_crashid.c
69index bca44e0e..8dd98d70 100644
70--- a/src/core_dump_handler/dlt_cdh_crashid.c
71+++ b/src/core_dump_handler/dlt_cdh_crashid.c
72@@ -30,7 +30,7 @@
73 #include <stdio.h>
74 #include <string.h>
75 #include <errno.h>
76-#include <asm/prctl.h>
77+#include <sys/prctl.h>
78 #include <inttypes.h>
79
80 #include "dlt_cdh.h"
diff --git a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.10.bb b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.10.bb
index 3811772a7..1522d02c2 100644
--- a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.10.bb
+++ b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.10.bb
@@ -17,6 +17,7 @@ DEPENDS = "zlib gzip-native json-c"
17SRC_URI = "git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \ 17SRC_URI = "git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
18 file://0002-Don-t-execute-processes-as-a-specific-user.patch \ 18 file://0002-Don-t-execute-processes-as-a-specific-user.patch \
19 file://0004-Modify-systemd-config-directory.patch \ 19 file://0004-Modify-systemd-config-directory.patch \
20 file://544.patch \
20 " 21 "
21SRCREV = "0f2d4cfffada6f8448a2cb27995b38eb4271044f" 22SRCREV = "0f2d4cfffada6f8448a2cb27995b38eb4271044f"
22 23
@@ -47,6 +48,8 @@ PACKAGECONFIG[dlt-console] = "-DWITH_DLT_CONSOLE=ON,-DWITH_DLT_CONSOLE=OFF"
47 48
48inherit autotools gettext cmake pkgconfig systemd 49inherit autotools gettext cmake pkgconfig systemd
49 50
51# -DWITH_DLT_COREDUMPHANDLER=ON this feature is too experimental, disable for now
52#FILES:${PN} += "${libdir}/sysctl.d"
50EXTRA_OECMAKE += "-DWITH_DLT_LOGSTORAGE_GZIP=ON -DWITH_EXTENDED_FILTERING=ON -DSYSTEMD_UNITDIR=${systemd_system_unitdir}" 53EXTRA_OECMAKE += "-DWITH_DLT_LOGSTORAGE_GZIP=ON -DWITH_EXTENDED_FILTERING=ON -DSYSTEMD_UNITDIR=${systemd_system_unitdir}"
51 54
52PACKAGES += "${PN}-systemd" 55PACKAGES += "${PN}-systemd"