summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb')
-rw-r--r--meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb b/meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb
new file mode 100644
index 000000000..ac5f7559b
--- /dev/null
+++ b/meta-oe/recipes-extended/boinc/boinc-client_7.6.33.bb
@@ -0,0 +1,77 @@
1# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Open-source software for volunteer computing"
5DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
6source software platform which supports distributed computing, primarily in \
7the form of volunteer computing and desktop Grid computing. It is well \
8suited for problems which are often described as trivially parallel. BOINC \
9is the underlying software used by projects such as SETI@home, Einstein@Home, \
10ClimatePrediciton.net, the World Community Grid, and many other distributed \
11computing projects. \
12This package installs the BOINC client software, which will allow your \
13computer to participate in one or more BOINC projects, using your spare \
14computer time to search for cures for diseases, model protein folding, study \
15global warming, discover sources of gravitational waves, and many other types \
16of scientific and mathematical research."
17
18HOMEPAGE = "http://boinc.berkeley.edu/"
19LICENSE = "LGPLv2+ & GPLv3"
20LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
22SECTION = "applications"
23DEPENDS = "curl \
24 jpeg \
25 openssl \
26 sqlite3 \
27 virtual/libgl \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
30 nettle \
31"
32
33SRC_URI = "https://github.com/BOINC/boinc/archive/client_release/7.6/${PV}.tar.gz \
34 file://boinc-AM_CONDITIONAL.patch \
35 file://opengl_m4_check.patch \
36 file://cross-compile.patch \
37 file://gtk-configure.patch \
38"
39SRC_URI[md5sum] = "437b4b98e384b4bda4ef7056e68166ac"
40SRC_URI[sha256sum] = "c4b1c29b9655013e0ac61dddf47ad7f30f38c46159f02a9d9dc8ab854e99aa6d"
41
42inherit gettext autotools-brokensep pkgconfig
43
44S = "${WORKDIR}/${BPN}_release-7.6-${PV}"
45
46EXTRA_OECONF += "\
47 --enable-libraries \
48 --enable-unicode \
49 --enable-shared \
50 --enable-dynamic-client-linkage \
51 --enable-client \
52 --disable-server \
53 --disable-static \
54 --disable-manager \
55 --with-ssl=${STAGING_EXECPREFIXDIR} \
56 --without-wxdir \
57 --without-x \
58 --with-boinc-platform=${TARGET_SYS} \
59"
60export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
61
62do_configure_prepend () {
63 if "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0"
64 then
65 export GTK2_CFLAGS=""
66 export GTK2_LIBS=""
67 fi
68}
69
70do_compile_prepend () {
71 # Disable rpaths
72 sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
73 sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
74 sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
75}
76
77SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"