summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/atftp/atftp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/atftp/atftp_git.bb')
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/atftp/atftp_git.bb b/meta-oe/recipes-extended/atftp/atftp_git.bb
new file mode 100644
index 000000000..774dd6884
--- /dev/null
+++ b/meta-oe/recipes-extended/atftp/atftp_git.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Advanced TFTP server and client"
2SECTION = "network"
3HOMEPAGE = "http://packages.debian.org/atftp"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.7.1+git${SRCPV}"
7
8SRCREV = "be3291a18c069ae23a124ffdc56d64a5ff0bbec7"
9
10SRC_URI = "git://atftp.git.sourceforge.net/gitroot/atftp/atftp;protocol=git \
11 file://atftpd-0.7_circumvent_tftp_size_restrictions.patch \
12 file://atftpd-0.7_unprotected_assignments_crash.patch \
13 file://atftpd.init \
14 "
15S = "${WORKDIR}/git"
16
17inherit autotools update-rc.d useradd
18
19INITSCRIPT_PACKAGES = "${PN}d"
20INITSCRIPT_NAME_${PN}d = "atftpd"
21INITSCRIPT_PARAMS_${PN}d = "defaults 80"
22
23USERADD_PACKAGES = "${PN}d"
24USERADD_PARAM_${PN}d = "--system --no-create-home --shell /bin/false \
25 --user-group nobody"
26
27do_install_append() {
28 install -d ${D}${sysconfdir}/init.d
29 install -m 0755 ${WORKDIR}/atftpd.init ${D}${sysconfdir}/init.d/atftpd
30
31 install -d ${D}/srv/tftp
32
33 rm ${D}${sbindir}/in.tftpd
34}
35
36PACKAGES =+ "atftpd"
37
38FILES_${PN} = "${bindir}/*"
39
40FILES_${PN}d = "${sbindir}/* ${sysconfdir}/init.d/* /srv/tftp"