diff options
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/musl/musl-nscd_git.bb | 6 |
2 files changed, 46 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch b/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch new file mode 100644 index 000000000..6fee0526d --- /dev/null +++ b/meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 8c0e4b7907eb577b1e5214f9a7bc75d5c3263b0a Mon Sep 17 00:00:00 2001 | ||
2 | From: Ariadne Conill <ariadne@dereferenced.org> | ||
3 | Date: Sat, 14 Nov 2020 22:55:30 -0700 | ||
4 | Subject: [PATCH] Fix build under GCC -fno-common. | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/pikhq/musl-nscd/pull/11] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | include/modules.h | 4 ++-- | ||
10 | src/main.c | 3 +++ | ||
11 | 2 files changed, 5 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/include/modules.h b/include/modules.h | ||
14 | index 70c1960..e77ec58 100644 | ||
15 | --- a/include/modules.h | ||
16 | +++ b/include/modules.h | ||
17 | @@ -28,7 +28,7 @@ struct mod_passwd { | ||
18 | link_t link; | ||
19 | }; | ||
20 | |||
21 | -list_t passwd_mods; | ||
22 | -list_t group_mods; | ||
23 | +extern list_t passwd_mods; | ||
24 | +extern list_t group_mods; | ||
25 | |||
26 | #endif | ||
27 | diff --git a/src/main.c b/src/main.c | ||
28 | index c1a78bb..808ef74 100644 | ||
29 | --- a/src/main.c | ||
30 | +++ b/src/main.c | ||
31 | @@ -18,6 +18,9 @@ | ||
32 | #include "parse.h" | ||
33 | #include "util.h" | ||
34 | |||
35 | +list_t passwd_mods; | ||
36 | +list_t group_mods; | ||
37 | + | ||
38 | static void *get_dll(const char *service) | ||
39 | { | ||
40 | char *path; | ||
41 | -- | ||
42 | 2.29.2 | ||
43 | |||
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb index b03cc868f..94a506ae7 100644 --- a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb +++ b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb | |||
@@ -9,10 +9,10 @@ SECTION = "utils" | |||
9 | 9 | ||
10 | PV = "1.0.2" | 10 | PV = "1.0.2" |
11 | 11 | ||
12 | CFLAGS += "-fcommon" | ||
13 | |||
14 | SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4" | 12 | SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4" |
15 | SRC_URI = "git://github.com/pikhq/musl-nscd" | 13 | SRC_URI = "git://github.com/pikhq/musl-nscd \ |
14 | file://0001-Fix-build-under-GCC-fno-common.patch \ | ||
15 | " | ||
16 | 16 | ||
17 | UPSTREAM_CHECK_COMMITS = "1" | 17 | UPSTREAM_CHECK_COMMITS = "1" |
18 | 18 | ||