diff options
Diffstat (limited to 'meta-oe/recipes-devtools')
5 files changed, 82 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-epydoc_3.0.1.bb b/meta-oe/recipes-devtools/python/python-epydoc_3.0.1.bb new file mode 100644 index 000000000..4ec066857 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-epydoc_3.0.1.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "Epydoc is a tool for generating API documentation for Python modules, based on their docstrings" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=011c0d78eb6054d731c879132d7313f0" | ||
5 | HOMEPAGE = "http://epydoc.sourceforge.net/" | ||
6 | SRCNAME = "epydoc" | ||
7 | DEPENDS += "python" | ||
8 | DEPENDS_virtclass-native += "python-native" | ||
9 | |||
10 | SRC_URI = "http://downloads.sourceforge.net/project/${SRCNAME}/${SRCNAME}/${PV}/${SRCNAME}-${PV}.tar.gz" | ||
11 | SRC_URI[md5sum] = "cdd6f6c76dd8bab5e653a343a0544294" | ||
12 | SRC_URI[sha256sum] = "d4e5c8d90937d01b05170f592c1fa9b29e9ed0498dfe7f0eb2a3af61725b6ad1" | ||
13 | |||
14 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
15 | |||
16 | inherit distutils | ||
17 | |||
18 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-devtools/python/python-gdata_1.2.4.bb b/meta-oe/recipes-devtools/python/python-gdata_1.2.4.bb new file mode 100644 index 000000000..7351759ab --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-gdata_1.2.4.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "Google Data APIs Python Client Library" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://README.txt;md5=473bd4dff0ddca1f958244b2dc7a162c" | ||
5 | HOMEPAGE = "http://code.google.com/p/gdata-python-client/" | ||
6 | |||
7 | inherit distutils | ||
8 | |||
9 | SRC_URI = "http://gdata-python-client.googlecode.com/files/gdata.py-${PV}.tar.gz" | ||
10 | SRC_URI[md5sum] = "521f33a377d64f8a6505ba119415b787" | ||
11 | SRC_URI[sha256sum] = "fc5ddb8f76b17abd728721a0e0177ea35f55a70106f44dc9010b22eceb06abde" | ||
12 | |||
13 | S = "${WORKDIR}/gdata.py-${PV}" | ||
14 | |||
15 | FILES_${PN} += "${datadir}" | ||
16 | |||
17 | RDEPENDS_${PN} = "python-elementtree" | ||
18 | |||
diff --git a/meta-oe/recipes-devtools/python/python-ldap/setup.cfg.patch b/meta-oe/recipes-devtools/python/python-ldap/setup.cfg.patch new file mode 100644 index 000000000..a703d342e --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-ldap/setup.cfg.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | --- python-ldap-2.3.9/setup.cfg.orig 2009-08-13 11:07:23.000000000 +0200 | ||
2 | +++ python-ldap-2.3.9/setup.cfg 2009-08-13 11:07:37.000000000 +0200 | ||
3 | @@ -1,9 +1,9 @@ | ||
4 | [_ldap] | ||
5 | extra_objects = | ||
6 | extra_compile_args = | ||
7 | -libs = ldap_r lber sasl2 ssl crypto | ||
8 | +libs = ldap_r lber ssl crypto | ||
9 | library_dirs = /opt/openldap-RE24/lib | ||
10 | -include_dirs = /opt/openldap-RE24/include /usr/include/sasl | ||
11 | +include_dirs = /opt/openldap-RE24/include | ||
12 | |||
13 | [egg_info] | ||
14 | tag_build = | ||
diff --git a/meta-oe/recipes-devtools/python/python-ldap_2.3.9.bb b/meta-oe/recipes-devtools/python/python-ldap_2.3.9.bb new file mode 100644 index 000000000..dfe1522fd --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-ldap_2.3.9.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "LDAP client API for Python, C wrapper module around OpenLDAP 2.x with an object-oriented API" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "Python-style" | ||
4 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a41c82edffa04912007cae1d20cac555" | ||
5 | HOMEPAGE = "http://www.python-ldap.org/" | ||
6 | DEPENDS = "python openldap" | ||
7 | |||
8 | SRC_URI = "http://pypi.python.org/packages/source/p/${PN}/${PN}-${PV}.tar.gz \ | ||
9 | file://setup.cfg.patch" | ||
10 | SRC_URI[md5sum] = "a9f9f16338288d118a1ae6266c993247" | ||
11 | SRC_URI[sha256sum] = "62f75b21c5ee744408c9d8b59878328b3bdf47899d30e8abf0c09b3ffb893ed4" | ||
12 | |||
13 | inherit setuptools | ||
diff --git a/meta-oe/recipes-devtools/python/python-webdav_0.1.2.bb b/meta-oe/recipes-devtools/python/python-webdav_0.1.2.bb new file mode 100644 index 000000000..7a6437dc5 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-webdav_0.1.2.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "This project aims to provide an object-oriented Python WebDAV client-side library\ | ||
2 | based on Python`s standard httplib and Greg Stein`s davlib.\ | ||
3 | The client shall fully support RFCs 4918 (basic specification),\ | ||
4 | 3744 (access control), and 3253 (versioning)." | ||
5 | SECTION = "devel/python" | ||
6 | LICENSE = "Apache-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://src/webdav/WebdavClient.py;endline=15;md5=a1520fad859feb7b0d7f05277bc6ce48" | ||
8 | HOMEPAGE = "http://sourceforge.net/projects/pythonwebdavlib/" | ||
9 | SRCNAME = "Python_WebDAV_Library" | ||
10 | DEPENDS = "python" | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/pythonwebdavlib/Python%20WebDAV%20Library%20-%20${PV}/${SRCNAME}-${PV}.zip" | ||
13 | SRC_URI[md5sum] = "8e49e0ecc5b4327c4f752a544ee10e1a" | ||
14 | SRC_URI[sha256sum] = "72c029ad1e25de950f59c2f1812d009d2c1691b70e4b5b09f1af9006e8fd5f23" | ||
15 | |||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | inherit distutils | ||
19 | |||