diff options
Diffstat (limited to 'meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb')
-rw-r--r-- | meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb new file mode 100644 index 000000000..a34256c27 --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.60.03.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ | ||
2 | write an XML-RPC server or client in C or C++." | ||
3 | |||
4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" | ||
5 | LICENSE = "BSD-3-Clause & MIT" | ||
6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" | ||
7 | |||
8 | SRC_URI = "git://github.com/mirror/xmlrpc-c.git;branch=master;protocol=https \ | ||
9 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ | ||
10 | " | ||
11 | # one more commit after Release 1.60.03 in the Stable series | ||
12 | SRCREV = "a823b0bb5cf0a4dbd34f929cbfdfb0439c5d9b0e" | ||
13 | |||
14 | S = "${WORKDIR}/git/stable" | ||
15 | |||
16 | inherit autotools-brokensep binconfig pkgconfig | ||
17 | |||
18 | TARGET_CFLAGS += "-Wno-narrowing" | ||
19 | |||
20 | EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \ | ||
21 | LD_FOR_BUILD='${BUILD_LD}' \ | ||
22 | CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \ | ||
23 | LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \ | ||
24 | " | ||
25 | |||
26 | EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client" | ||
27 | |||
28 | PACKAGECONFIG ??= "curl cplusplus" | ||
29 | |||
30 | PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl" | ||
31 | PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus" | ||
32 | PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl" | ||
33 | |||
34 | do_configure() { | ||
35 | gnu-configize --verbose --force ${S} | ||
36 | autoconf | ||
37 | oe_runconf | ||
38 | # license is incompatible with lib/util/getoptx.* | ||
39 | rm -fv ${S}/tools/turbocharger/mod_gzip.c | ||
40 | } | ||
41 | |||
42 | do_install:append:class-target() { | ||
43 | sed -i 's,${WORKDIR},${TARGET_DBGSRC_DIR},g' ${D}${bindir}/xmlrpc-c-config | ||
44 | } | ||
45 | |||
46 | BBCLASSEXTEND = "native" | ||
47 | |||
48 | CLEANBROKEN = "1" | ||