summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb4
-rw-r--r--meta-oe/recipes-devtools/python/python-mako_0.7.2.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python-matplotlib_1.1.0.bb8
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb24
-rw-r--r--meta-oe/recipes-devtools/python/python-pexpect_2.3.bb10
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt_4.9.6.bb38
-rw-r--r--meta-oe/recipes-devtools/python/python-pyserial_2.4.bb6
-rw-r--r--meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb6
-rw-r--r--meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python-pyyaml_3.10.bb6
-rw-r--r--meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb10
-rw-r--r--meta-oe/recipes-devtools/python/python-sip_4.14.2.bb16
-rw-r--r--meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb8
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado_git.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb80
15 files changed, 111 insertions, 111 deletions
diff --git a/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb b/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb
index a449f0339..2d913e4ee 100644
--- a/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb
+++ b/meta-oe/recipes-devtools/python/python-dateutil_1.4.1.bb
@@ -15,8 +15,8 @@ PACKAGES =+ "${PN}-zoneinfo"
15FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" 15FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
16 16
17RDEPENDS_${PN} = "\ 17RDEPENDS_${PN} = "\
18 python-core \ 18 python-core \
19 python-datetime \ 19 python-datetime \
20" 20"
21 21
22SRC_URI[md5sum] = "2a5f25ab12fcefcf0b21348f2d47595a" 22SRC_URI[md5sum] = "2a5f25ab12fcefcf0b21348f2d47595a"
diff --git a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
index 6f71561bd..9e381f3dc 100644
--- a/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
+++ b/meta-oe/recipes-devtools/python/python-mako_0.7.2.bb
@@ -16,4 +16,4 @@ inherit setuptools
16RDEPENDS_${PN} = "python-threading \ 16RDEPENDS_${PN} = "python-threading \
17 python-netclient \ 17 python-netclient \
18 python-html \ 18 python-html \
19 " 19"
diff --git a/meta-oe/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-oe/recipes-devtools/python/python-matplotlib_1.1.0.bb
index 788ba2f7c..7bb61fd57 100644
--- a/meta-oe/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ b/meta-oe/recipes-devtools/python/python-matplotlib_1.1.0.bb
@@ -10,7 +10,7 @@ RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng"
10SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \ 10SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \
11 file://fix_setup.patch \ 11 file://fix_setup.patch \
12 file://fix_setupext.patch \ 12 file://fix_setupext.patch \
13 " 13"
14 14
15S = "${WORKDIR}/matplotlib-${PV}" 15S = "${WORKDIR}/matplotlib-${PV}"
16 16
@@ -19,9 +19,9 @@ EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
19inherit distutils 19inherit distutils
20 20
21do_compile_prepend() { 21do_compile_prepend() {
22 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ 22 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
23 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ 23 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
24 true 24 true
25} 25}
26 26
27# need to export these variables for python-config to work 27# need to export these variables for python-config to work
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index 23bec15bb..a3698d30f 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -9,18 +9,18 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
9CONFIGFILESURI ?= "" 9CONFIGFILESURI ?= ""
10 10
11CONFIGFILESURI_aarch64 = "file://config.h \ 11CONFIGFILESURI_aarch64 = "file://config.h \
12 file://_numpyconfig.h \ 12 file://_numpyconfig.h \
13 " 13"
14CONFIGFILESURI_arm = "file://config.h \ 14CONFIGFILESURI_arm = "file://config.h \
15 file://numpyconfig.h \ 15 file://numpyconfig.h \
16 " 16"
17CONFIGFILESURI_mipsel = "file://config.h \ 17CONFIGFILESURI_mipsel = "file://config.h \
18 file://numpyconfig.h \ 18 file://numpyconfig.h \
19 " 19"
20 20
21CONFIGFILESURI_i586 = "file://config.h \ 21CONFIGFILESURI_i586 = "file://config.h \
22 file://numpyconfig.h \ 22 file://numpyconfig.h \
23 " 23"
24 24
25S = "${WORKDIR}/numpy-${PV}" 25S = "${WORKDIR}/numpy-${PV}"
26 26
@@ -29,10 +29,10 @@ inherit distutils
29# Make the build fail and replace *config.h with proper one 29# Make the build fail and replace *config.h with proper one
30# This is a ugly, ugly hack - Koen 30# This is a ugly, ugly hack - Koen
31do_compile_prepend() { 31do_compile_prepend() {
32 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ 32 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
33 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ 33 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
34 true 34 true
35 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ 35 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
36} 36}
37 37
38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" 38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
@@ -59,4 +59,4 @@ RDEPENDS_${PN} = "python-unittest \
59 python-email \ 59 python-email \
60 python-subprocess \ 60 python-subprocess \
61 python-compression \ 61 python-compression \
62 " 62"
diff --git a/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb b/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb
index d1b8530bc..1c64365da 100644
--- a/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb
+++ b/meta-oe/recipes-devtools/python/python-pexpect_2.3.bb
@@ -11,11 +11,11 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
11inherit distutils 11inherit distutils
12 12
13RDEPENDS_${PN} = "\ 13RDEPENDS_${PN} = "\
14 python-core \ 14 python-core \
15 python-io \ 15 python-io \
16 python-terminal \ 16 python-terminal \
17 python-resource \ 17 python-resource \
18 python-fcntl \ 18 python-fcntl \
19" 19"
20 20
21 21
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.9.6.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.9.6.bb
index 340796a7c..f21464a93 100644
--- a/meta-oe/recipes-devtools/python/python-pyqt_4.9.6.bb
+++ b/meta-oe/recipes-devtools/python/python-pyqt_4.9.6.bb
@@ -4,11 +4,11 @@ AUTHOR = "Phil Thomson @ riverbank.co.uk"
4SECTION = "devel/python" 4SECTION = "devel/python"
5LICENSE = "GPLv2 & GPLv3 & GPL_EXCEPTION" 5LICENSE = "GPLv2 & GPLv3 & GPL_EXCEPTION"
6LIC_FILES_CHKSUM = "\ 6LIC_FILES_CHKSUM = "\
7 file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \ 7 file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \
8 file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \ 8 file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \
9 file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \ 9 file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \
10 file://LICENSE.GPL2;md5=276c6b9cad5f85a3af3534299825feff \ 10 file://LICENSE.GPL2;md5=276c6b9cad5f85a3af3534299825feff \
11 file://LICENSE.GPL3;md5=eda942b9c6ba7eb0f40fee79e94950d5 \ 11 file://LICENSE.GPL3;md5=eda942b9c6ba7eb0f40fee79e94950d5 \
12" 12"
13 13
14DEPENDS = "sip-native python-sip" 14DEPENDS = "sip-native python-sip"
@@ -18,8 +18,8 @@ PYQT_OE_VERSION = "Qt_4_8_3"
18PR = "r1" 18PR = "r1"
19 19
20SRC_URI = "\ 20SRC_URI = "\
21 ${SOURCEFORGE_MIRROR}/pyqt/PyQt-x11-gpl-${PV}.tar.gz \ 21 ${SOURCEFORGE_MIRROR}/pyqt/PyQt-x11-gpl-${PV}.tar.gz \
22 file://pyqt-generated.patch;apply=no \ 22 file://pyqt-generated.patch;apply=no \
23" 23"
24SRC_URI[md5sum] = "514e1f9597771dc732ba75ba9fa5c6b6" 24SRC_URI[md5sum] = "514e1f9597771dc732ba75ba9fa5c6b6"
25SRC_URI[sha256sum] = "a350f9e5c6d8062671c0f29bf1a70824719b18175ce8372c29bf7c1eda44b18d" 25SRC_URI[sha256sum] = "a350f9e5c6d8062671c0f29bf1a70824719b18175ce8372c29bf7c1eda44b18d"
@@ -27,11 +27,11 @@ S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
27 27
28# arm and mips machines need some extra patches 28# arm and mips machines need some extra patches
29SRC_URI_append_arm = "\ 29SRC_URI_append_arm = "\
30 file://qreal_float_support.diff \ 30 file://qreal_float_support.diff \
31" 31"
32 32
33SRC_URI_append_mipsel = "\ 33SRC_URI_append_mipsel = "\
34 file://qreal_float_support.diff \ 34 file://qreal_float_support.diff \
35" 35"
36 36
37inherit qt4x11 sip distutils-base 37inherit qt4x11 sip distutils-base
@@ -51,16 +51,16 @@ SIP_MODULES = "QtCore QtDeclarative QtGui QtNetwork QtSql QtSvg QtXml QtWebKit"
51MAKE_MODULES = "qpy ${SIP_MODULES}" 51MAKE_MODULES = "qpy ${SIP_MODULES}"
52 52
53EXTRA_QMAKEVARS_POST += "\ 53EXTRA_QMAKEVARS_POST += "\
54 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/Qt \ 54 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/Qt \
55 INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \ 55 INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \
56 INCLUDEPATH+=../qpy/QtCore \ 56 INCLUDEPATH+=../qpy/QtCore \
57 INCLUDEPATH+=../qpy/QtGui \ 57 INCLUDEPATH+=../qpy/QtGui \
58 INCLUDEPATH+=../qpy/QtDeclarative \ 58 INCLUDEPATH+=../qpy/QtDeclarative \
59 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtCore \ 59 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtCore \
60 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtGui \ 60 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtGui \
61 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtDeclarative \ 61 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtDeclarative \
62 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtWebKit \ 62 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtWebKit \
63 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtNetwork \ 63 INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/QtNetwork \
64" 64"
65FIX_QREAL = "\ 65FIX_QREAL = "\
66" 66"
diff --git a/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
index 02ba6b7ba..0cce5cbc9 100644
--- a/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
+++ b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
@@ -13,9 +13,9 @@ inherit setuptools
13# FIXME might stop packaging serialwin32 and serialjava files 13# FIXME might stop packaging serialwin32 and serialjava files
14 14
15RDEPENDS_${PN} = "\ 15RDEPENDS_${PN} = "\
16 python-fcntl \ 16 python-fcntl \
17 python-io \ 17 python-io \
18 python-stringold \ 18 python-stringold \
19" 19"
20 20
21SRC_URI[md5sum] = "eec19df59fd75ba5a136992897f8e468" 21SRC_URI[md5sum] = "eec19df59fd75ba5a136992897f8e468"
diff --git a/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb b/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb
index ec54b4403..741d037cc 100644
--- a/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb
+++ b/meta-oe/recipes-devtools/python/python-pyudev_0.16.1.bb
@@ -19,7 +19,7 @@ do_configure_prepend() {
19} 19}
20 20
21RDEPENDS_${PN} = "\ 21RDEPENDS_${PN} = "\
22 python-ctypes \ 22 python-ctypes \
23 python-subprocess \ 23 python-subprocess \
24 python-misc \ 24 python-misc \
25" 25"
diff --git a/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb b/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb
index 40242829b..e5956dbdf 100644
--- a/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb
+++ b/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb
@@ -7,7 +7,7 @@ DEPENDS = "libusb1"
7PR = "r1" 7PR = "r1"
8 8
9SRC_URI = "\ 9SRC_URI = "\
10 ${SOURCEFORGE_MIRROR}/pyusb/${SRCNAME}-${PV}.tar.gz \ 10 ${SOURCEFORGE_MIRROR}/pyusb/${SRCNAME}-${PV}.tar.gz \
11" 11"
12SRC_URI[md5sum] = "9136b3dc019272c62a5b6d4eb624f89f" 12SRC_URI[md5sum] = "9136b3dc019272c62a5b6d4eb624f89f"
13SRC_URI[sha256sum] = "dacbf7d568c0bb09a974d56da66d165351f1ba3c4d5169ab5b734266623e1736" 13SRC_URI[sha256sum] = "dacbf7d568c0bb09a974d56da66d165351f1ba3c4d5169ab5b734266623e1736"
diff --git a/meta-oe/recipes-devtools/python/python-pyyaml_3.10.bb b/meta-oe/recipes-devtools/python/python-pyyaml_3.10.bb
index 625efd59b..100e1c81a 100644
--- a/meta-oe/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/meta-oe/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -7,7 +7,7 @@ DEPENDS = "libyaml python-cython-native"
7 7
8SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \ 8SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \
9 file://setup.py \ 9 file://setup.py \
10 " 10"
11 11
12SRC_URI[md5sum] = "74c94a383886519e9e7b3dd1ee540247" 12SRC_URI[md5sum] = "74c94a383886519e9e7b3dd1ee540247"
13SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d46fe7c" 13SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d46fe7c"
@@ -17,6 +17,6 @@ S = "${WORKDIR}/PyYAML-${PV}"
17inherit distutils 17inherit distutils
18 18
19do_configure_prepend() { 19do_configure_prepend() {
20 # upstream setup.py overcomplicated, use ours 20 # upstream setup.py overcomplicated, use ours
21 install -m 0644 ${WORKDIR}/setup.py ${S} 21 install -m 0644 ${WORKDIR}/setup.py ${S}
22} 22}
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
index 6be59c927..85d69c1a7 100644
--- a/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
+++ b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
@@ -17,11 +17,11 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17inherit distutils 17inherit distutils
18 18
19RDEPENDS_${PN} = "\ 19RDEPENDS_${PN} = "\
20 python-core \ 20 python-core \
21 python-re \ 21 python-re \
22 python-io \ 22 python-io \
23 python-netserver \ 23 python-netserver \
24 python-numbers \ 24 python-numbers \
25" 25"
26 26
27 27
diff --git a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb b/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb
index 1159a2abb..747d89632 100644
--- a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb
+++ b/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb
@@ -29,17 +29,17 @@ EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \
29 29
30 30
31do_configure_prepend() { 31do_configure_prepend() {
32 cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro 32 cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro
33 cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c 33 cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c
34 cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h 34 cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h
35} 35}
36 36
37do_install() { 37do_install() {
38 install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/ 38 install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
39 install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so 39 install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so
40 # sipconfig.py sipdistutils.py 40 # sipconfig.py sipdistutils.py
41 install -d ${D}${includedir} 41 install -d ${D}${includedir}
42 install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h 42 install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h
43} 43}
44 44
45FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so" 45FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so"
diff --git a/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb b/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb
index 5ba24c6ef..3085d2f3c 100644
--- a/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb
+++ b/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8" 3LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
4 4
5SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \ 5SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \
6 " 6"
7SRC_URI[md5sum] = "511376eed04455cdb277ef19c5f73bb4" 7SRC_URI[md5sum] = "511376eed04455cdb277ef19c5f73bb4"
8SRC_URI[sha256sum] = "23b28e474741834e3f1b35b0686528769a13adc92d2ff5603cbda1d6bd5e5629" 8SRC_URI[sha256sum] = "23b28e474741834e3f1b35b0686528769a13adc92d2ff5603cbda1d6bd5e5629"
9 9
@@ -14,7 +14,7 @@ inherit distutils
14S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/" 14S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
15 15
16do_configure_prepend() { 16do_configure_prepend() {
17 # Adjust for OE header rename 17 # Adjust for OE header rename
18 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk 18 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
19 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c 19 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
20} 20}
diff --git a/meta-oe/recipes-devtools/python/python-tornado_git.bb b/meta-oe/recipes-devtools/python/python-tornado_git.bb
index f158923ff..9c58e94bc 100644
--- a/meta-oe/recipes-devtools/python/python-tornado_git.bb
+++ b/meta-oe/recipes-devtools/python/python-tornado_git.bb
@@ -7,7 +7,7 @@ PV = "2.2.1+git${SRCPV}"
7SRCREV = "c501917eba46dec30b1f2ef12497dffc4beec505" 7SRCREV = "c501917eba46dec30b1f2ef12497dffc4beec505"
8SRC_URI = "git://github.com/facebook/tornado.git;branch=branch2.2 \ 8SRC_URI = "git://github.com/facebook/tornado.git;branch=branch2.2 \
9 file://0001-disable-AI_ADDRCONFIG-flag.patch \ 9 file://0001-disable-AI_ADDRCONFIG-flag.patch \
10 " 10"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
diff --git a/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb b/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
index 532094675..d585bfab4 100644
--- a/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
+++ b/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
@@ -23,68 +23,68 @@ do_install_append() {
23} 23}
24 24
25PACKAGES += "\ 25PACKAGES += "\
26 ${PN}-zsh \ 26 ${PN}-zsh \
27 ${PN}-test \ 27 ${PN}-test \
28 ${PN}-protocols \ 28 ${PN}-protocols \
29 ${PN}-bin \ 29 ${PN}-bin \
30 ${PN}-conch \ 30 ${PN}-conch \
31 ${PN}-lore \ 31 ${PN}-lore \
32 ${PN}-mail \ 32 ${PN}-mail \
33 ${PN}-names \ 33 ${PN}-names \
34 ${PN}-news \ 34 ${PN}-news \
35 ${PN}-runner \ 35 ${PN}-runner \
36 ${PN}-web \ 36 ${PN}-web \
37 ${PN}-words \ 37 ${PN}-words \
38 ${PN}-flow \ 38 ${PN}-flow \
39 ${PN}-pair \ 39 ${PN}-pair \
40 ${PN}-core \ 40 ${PN}-core \
41" 41"
42 42
43RDEPENDS_${PN} = "python-core python-zopeinterface" 43RDEPENDS_${PN} = "python-core python-zopeinterface"
44RDEPENDS_${PN} += "\ 44RDEPENDS_${PN} += "\
45 ${PN}-bin \ 45 ${PN}-bin \
46 ${PN}-conch \ 46 ${PN}-conch \
47 ${PN}-lore \ 47 ${PN}-lore \
48 ${PN}-mail \ 48 ${PN}-mail \
49 ${PN}-names \ 49 ${PN}-names \
50 ${PN}-news \ 50 ${PN}-news \
51 ${PN}-runner \ 51 ${PN}-runner \
52 ${PN}-web \ 52 ${PN}-web \
53 ${PN}-words \ 53 ${PN}-words \
54" 54"
55 55
56ALLOW_EMPTY_${PN} = "1" 56ALLOW_EMPTY_${PN} = "1"
57FILES_${PN} = "" 57FILES_${PN} = ""
58 58
59FILES_${PN}-test = " \ 59FILES_${PN}-test = " \
60 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ 60 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
61 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ 61 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
62" 62"
63 63
64FILES_${PN}-protocols = " \ 64FILES_${PN}-protocols = " \
65 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \ 65 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
66 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \ 66 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
67 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \ 67 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
68" 68"
69 69
70FILES_${PN}-zsh = " \ 70FILES_${PN}-zsh = " \
71 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ 71 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
72 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \ 72 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
73" 73"
74 74
75FILES_${PN}-bin = " \ 75FILES_${PN}-bin = " \
76 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \ 76 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \
77 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \ 77 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \
78" 78"
79 79
80FILES_${PN}-conch = " \ 80FILES_${PN}-conch = " \
81 ${bindir}/ckeygen \ 81 ${bindir}/ckeygen \
82 ${bindir}/tkconch \ 82 ${bindir}/tkconch \
83 ${bindir}/conch \ 83 ${bindir}/conch \
84 ${bindir}/conchftp \ 84 ${bindir}/conchftp \
85 ${bindir}/cftp \ 85 ${bindir}/cftp \
86 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ 86 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ 87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
88" 88"
89 89
90FILES_${PN}-core = " \ 90FILES_${PN}-core = " \