diff options
Diffstat (limited to 'meta-oe/recipes-devtools/python')
9 files changed, 204 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb b/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb new file mode 100644 index 000000000..e3ecb1c08 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-cheetah_2.4.4.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "Python template engine and code generation tool" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "MIT" | ||
5 | SRCNAME = "Cheetah" | ||
6 | PR = "r1" | ||
7 | |||
8 | SRC_URI = "http://pypi.python.org/packages/source/C/Cheetah/Cheetah-${PV}.tar.gz" | ||
9 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
10 | |||
11 | inherit setuptools | ||
12 | |||
13 | RDEPENDS_${PN} = "python-pickle python-pprint" | ||
14 | |||
15 | NATIVE_INSTALL_WORKS = "1" | ||
16 | BBCLASSEXTEND = "native" | ||
17 | |||
18 | SRC_URI[md5sum] = "853917116e731afbc8c8a43c37e6ddba" | ||
19 | SRC_URI[sha256sum] = "be308229f0c1e5e5af4f27d7ee06d90bb19e6af3059794e5fd536a6f29a9b550" | ||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/config.h b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h new file mode 100644 index 000000000..17ef186d5 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h | |||
@@ -0,0 +1,21 @@ | |||
1 | /* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */ | ||
2 | /* #define SIZEOF_SHORT 2 */ | ||
3 | /* #define SIZEOF_INT 4 */ | ||
4 | /* #define SIZEOF_LONG 4 */ | ||
5 | /* #define SIZEOF_FLOAT 4 */ | ||
6 | /* #define SIZEOF_DOUBLE 8 */ | ||
7 | #define SIZEOF_LONG_DOUBLE 12 | ||
8 | #define SIZEOF_PY_INTPTR_T 4 | ||
9 | /* #define SIZEOF_LONG_LONG 8 */ | ||
10 | #define SIZEOF_PY_LONG_LONG 8 | ||
11 | /* #define CHAR_BIT 8 */ | ||
12 | #define MATHLIB m | ||
13 | #define HAVE_FLOAT_FUNCS | ||
14 | #define HAVE_LOG1P | ||
15 | #define HAVE_EXPM1 | ||
16 | #define HAVE_INVERSE_HYPERBOLIC | ||
17 | #define HAVE_INVERSE_HYPERBOLIC_FLOAT | ||
18 | #define HAVE_ISNAN | ||
19 | #define HAVE_ISINF | ||
20 | #define HAVE_RINT | ||
21 | |||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h new file mode 100644 index 000000000..c4bf6547f --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h | |||
@@ -0,0 +1,17 @@ | |||
1 | /* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */ | ||
2 | /* | ||
3 | * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT | ||
4 | * */ | ||
5 | #define NPY_SIZEOF_SHORT 2 | ||
6 | #define NPY_SIZEOF_INT 4 | ||
7 | #define NPY_SIZEOF_LONG 4 | ||
8 | #define NPY_SIZEOF_FLOAT 4 | ||
9 | #define NPY_SIZEOF_DOUBLE 8 | ||
10 | #define NPY_SIZEOF_LONGDOUBLE 12 | ||
11 | #define NPY_SIZEOF_PY_INTPTR_T 4 | ||
12 | #define NPY_NO_SMP 0 | ||
13 | |||
14 | #define NPY_SIZEOF_LONGLONG 8 | ||
15 | #define NPY_SIZEOF_PY_LONG_LONG 8 | ||
16 | /* #define CHAR_BIT 8 */ | ||
17 | |||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h new file mode 100644 index 000000000..17ef186d5 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h | |||
@@ -0,0 +1,21 @@ | |||
1 | /* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */ | ||
2 | /* #define SIZEOF_SHORT 2 */ | ||
3 | /* #define SIZEOF_INT 4 */ | ||
4 | /* #define SIZEOF_LONG 4 */ | ||
5 | /* #define SIZEOF_FLOAT 4 */ | ||
6 | /* #define SIZEOF_DOUBLE 8 */ | ||
7 | #define SIZEOF_LONG_DOUBLE 12 | ||
8 | #define SIZEOF_PY_INTPTR_T 4 | ||
9 | /* #define SIZEOF_LONG_LONG 8 */ | ||
10 | #define SIZEOF_PY_LONG_LONG 8 | ||
11 | /* #define CHAR_BIT 8 */ | ||
12 | #define MATHLIB m | ||
13 | #define HAVE_FLOAT_FUNCS | ||
14 | #define HAVE_LOG1P | ||
15 | #define HAVE_EXPM1 | ||
16 | #define HAVE_INVERSE_HYPERBOLIC | ||
17 | #define HAVE_INVERSE_HYPERBOLIC_FLOAT | ||
18 | #define HAVE_ISNAN | ||
19 | #define HAVE_ISINF | ||
20 | #define HAVE_RINT | ||
21 | |||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h new file mode 100644 index 000000000..c4bf6547f --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h | |||
@@ -0,0 +1,17 @@ | |||
1 | /* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */ | ||
2 | /* | ||
3 | * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT | ||
4 | * */ | ||
5 | #define NPY_SIZEOF_SHORT 2 | ||
6 | #define NPY_SIZEOF_INT 4 | ||
7 | #define NPY_SIZEOF_LONG 4 | ||
8 | #define NPY_SIZEOF_FLOAT 4 | ||
9 | #define NPY_SIZEOF_DOUBLE 8 | ||
10 | #define NPY_SIZEOF_LONGDOUBLE 12 | ||
11 | #define NPY_SIZEOF_PY_INTPTR_T 4 | ||
12 | #define NPY_NO_SMP 0 | ||
13 | |||
14 | #define NPY_SIZEOF_LONGLONG 8 | ||
15 | #define NPY_SIZEOF_PY_LONG_LONG 8 | ||
16 | /* #define CHAR_BIT 8 */ | ||
17 | |||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff new file mode 100644 index 000000000..3ab3d72f2 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff | |||
@@ -0,0 +1,33 @@ | |||
1 | --- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200 | ||
2 | +++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200 | ||
3 | @@ -80,8 +80,7 @@ | ||
4 | raise SystemError,\ | ||
5 | "Non-existing %s. Perhaps you need to install"\ | ||
6 | " python-dev|python-devel." % (python_h) | ||
7 | - result = config_cmd.try_run(tc,include_dirs=[python_include], | ||
8 | - library_dirs = default_lib_dirs) | ||
9 | + result = config_cmd.try_compile(tc) | ||
10 | if not result: | ||
11 | raise SystemError,"Failed to test configuration. "\ | ||
12 | "See previous error messages for more information." | ||
13 | @@ -95,7 +94,7 @@ | ||
14 | if mathlib: | ||
15 | mathlibs_choices.insert(0,mathlib.split(',')) | ||
16 | for libs in mathlibs_choices: | ||
17 | - if config_cmd.try_run(tc,libraries=libs): | ||
18 | + if config_cmd.try_compile(tc): | ||
19 | mathlibs = libs | ||
20 | break | ||
21 | else: | ||
22 | @@ -180,10 +179,7 @@ | ||
23 | " python-dev|python-devel." % (python_h) | ||
24 | |||
25 | config.numpy_include_dirs | ||
26 | - result = config_cmd.try_run(testcode, | ||
27 | - include_dirs = [python_include] + \ | ||
28 | - config.numpy_include_dirs, | ||
29 | - library_dirs = default_lib_dirs) | ||
30 | + result = config_cmd.try_compile(testcode) | ||
31 | |||
32 | if not result: | ||
33 | raise SystemError,"Failed to generate numpy configuration. "\ | ||
diff --git a/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff new file mode 100644 index 000000000..c5b448167 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff | |||
@@ -0,0 +1,16 @@ | |||
1 | --- /tmp/system_info.py 2008-08-22 00:38:16.000000000 +0200 | ||
2 | +++ numpy-1.1.1/numpy/distutils/system_info.py 2008-08-22 00:40:33.013198000 +0200 | ||
3 | @@ -137,11 +137,8 @@ | ||
4 | default_x11_lib_dirs = [] | ||
5 | default_x11_include_dirs = [] | ||
6 | else: | ||
7 | - default_lib_dirs = ['/usr/local/lib', '/opt/lib', '/usr/lib', | ||
8 | - '/opt/local/lib', '/sw/lib'] | ||
9 | - default_include_dirs = ['/usr/local/include', | ||
10 | - '/opt/include', '/usr/include', | ||
11 | - '/opt/local/include', '/sw/include'] | ||
12 | + default_lib_dirs = ['/non-existant-dir'] | ||
13 | + default_include_dirs = ['non-existant-dir'] | ||
14 | default_src_dirs = ['.','/usr/local/src', '/opt/src','/sw/src'] | ||
15 | |||
16 | try: | ||
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb b/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb new file mode 100644 index 000000000..ed47f47db --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy_1.4.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "PSF" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3c42211d73c3faa1026e671dd39883fa" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ | ||
8 | file://config.h \ | ||
9 | file://numpyconfig.h \ | ||
10 | " | ||
11 | |||
12 | S = "${WORKDIR}/numpy-${PV}" | ||
13 | |||
14 | inherit distutils | ||
15 | |||
16 | # Make the build fail and replace *config.h with proper one | ||
17 | # This is a ugly, ugly hack - Koen | ||
18 | do_compile_prepend() { | ||
19 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
20 | ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
21 | true | ||
22 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ | ||
23 | } | ||
24 | |||
25 | SRC_URI[md5sum] = "5c7b5349dc3161763f7f366ceb96516b" | ||
26 | SRC_URI[sha256sum] = "2e7bb84573e5123e07f3c919fd433bc09b78d606252b6b719e385c2a981d8e06" | ||
diff --git a/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb new file mode 100644 index 000000000..6b17a41f7 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-setuptools_0.6c11.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages" | ||
2 | HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools" | ||
3 | SECTION = "devel/python" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "PSF" | ||
6 | LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e" | ||
7 | |||
8 | SRCNAME = "setuptools" | ||
9 | PR = "ml2" | ||
10 | DEPENDS += "python" | ||
11 | DEPENDS_virtclass-native += "python-native" | ||
12 | |||
13 | SRC_URI = "\ | ||
14 | http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\ | ||
15 | " | ||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | inherit distutils | ||
19 | |||
20 | do_install_prepend() { | ||
21 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages | ||
22 | } | ||
23 | |||
24 | RDEPENDS_${PN} = "\ | ||
25 | python-distutils \ | ||
26 | python-compression \ | ||
27 | " | ||
28 | |||
29 | SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e" | ||
30 | SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3" | ||
31 | |||
32 | BBCLASSEXTEND = "native" | ||
33 | |||
34 | NATIVE_INSTALL_WORKS = "1" | ||