summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-pyserial_2.4.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyserial_2.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
new file mode 100644
index 000000000..cc138d196
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyserial_2.4.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Serial Port Support for Python"
2SECTION = "devel/python"
3PRIORITY = "optional"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7424386ffe323e815ee62ee9ad591dd8"
6SRCNAME = "pyserial"
7PR = "ml2"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10S = "${WORKDIR}/${SRCNAME}-${PV}"
11
12inherit setuptools
13
14# FIXME might stop packaging serialwin32 and serialjava files
15
16RDEPENDS_${PN} = "\
17 python-fcntl \
18 python-io \
19 python-stringold \
20"
21
22SRC_URI[md5sum] = "eec19df59fd75ba5a136992897f8e468"
23SRC_URI[sha256sum] = "6b6a9e3d2fd5978c92c843e0109918a4bcac481eecae316254481c0e0f7e73c8"