summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
new file mode 100644
index 000000000..c444fbf05
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Python GObject bindings"
2HOMEPAGE = "http://www.pygtk.org/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
7inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
8
9PYTHON_BASEVERSION = "2.7"
10PYTHON_PN = "python"
11
12DEPENDS += "gnome-common-native python glib-2.0"
13
14SRCNAME="pygobject"
15SRC_URI = " \
16 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
17 file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
18"
19
20SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90"
21SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0"
22
23S = "${WORKDIR}/${SRCNAME}-${PV}"
24
25BBCLASSEXTEND = "native"
26
27EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}"
28
29RDEPENDS_${PN} += "python-setuptools"
30RDEPENDS_${PN}_class-native = ""
31
32do_install_append() {
33 # Remove files that clash with python3-pygobject; their content is same
34 rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig
35}