diff options
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb new file mode 100644 index 000000000..bbe4e63b9 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | DESCRIPTION = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1" | ||
5 | |||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ | ||
7 | ${CONFIGFILESURI} " | ||
8 | |||
9 | CONFIGFILESURI ?= "" | ||
10 | |||
11 | CONFIGFILESURI_aarch64 = "file://config.h \ | ||
12 | file://_numpyconfig.h \ | ||
13 | " | ||
14 | CONFIGFILESURI_arm = "file://config.h \ | ||
15 | file://numpyconfig.h \ | ||
16 | " | ||
17 | CONFIGFILESURI_mipsel = "file://config.h \ | ||
18 | file://numpyconfig.h \ | ||
19 | " | ||
20 | |||
21 | S = "${WORKDIR}/numpy-${PV}" | ||
22 | |||
23 | inherit distutils | ||
24 | |||
25 | # Make the build fail and replace *config.h with proper one | ||
26 | # This is a ugly, ugly hack - Koen | ||
27 | do_compile_prepend() { | ||
28 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
29 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
30 | true | ||
31 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ | ||
32 | } | ||
33 | |||
34 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" | ||
35 | |||
36 | SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332" | ||
37 | SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6" | ||
38 | |||
39 | # install what is needed for numpy.test() | ||
40 | RDEPENDS_${PN} = "python-unittest \ | ||
41 | python-difflib \ | ||
42 | python-pprint \ | ||
43 | python-pickle \ | ||
44 | python-shell \ | ||
45 | python-nose \ | ||
46 | python-doctest \ | ||
47 | python-datetime \ | ||
48 | python-distutils \ | ||
49 | python-misc \ | ||
50 | python-mmap \ | ||
51 | python-netclient \ | ||
52 | python-numbers \ | ||
53 | python-pydoc \ | ||
54 | python-pkgutil \ | ||
55 | python-email \ | ||
56 | python-subprocess \ | ||
57 | python-compression \ | ||
58 | " | ||