summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb b/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb
new file mode 100644
index 000000000..5c1fa9cdf
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "A component which enables calling DBus methods and registering on DBus signals from Javascript"
2HOMEPAGE = "https://github.com/01org/cloudeebus"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
6
7SRC_URI = "git://github.com/01org/cloudeebus.git;protocol=http;branch=master "
8SRCREV = "b5cc957eeabfe98cb996baf8e5a0ac848993c3d4"
9
10S = "${WORKDIR}/git"
11
12inherit distutils
13
14DEPENDS_${PN} = "python python-setuptools"
15RDEPENDS_${PN} = "python python-dbus python-json python-argparse python-pygobject python-autobahn python-twisted python-subprocess"
16
17do_install_prepend() {
18 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}
19}
20
21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --single-version-externally-managed \
23 --prefix=${prefix} \
24 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
25 --install-data=${datadir}"
26
27do_install_append() {
28 distutils_do_install
29 install -d ${D}${datadir}/doc/${BPN}/
30 install -m 0644 ${S}/README.md ${D}${datadir}/doc/${BPN}/
31}
32
33FILES_${PN} += "${datadir}/cloudeebus"
34FILES_${PN} += "${sysconfdir}/dbus-1/system.d/org.cloudeebus.conf"
35