summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb b/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb
new file mode 100644
index 000000000..0208c8b50
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-autobahn_0.5.14.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "AutobahnPython provides a WebSocket (RFC6455, Hybi-10 to -17, Hixie-76) framework for creating WebSocket-based clients and servers. \
2AutobahnPython also includes an implementation of WAMP (The WebSockets Application Messaging Protocol), a light-weight, \
3asynchronous RPC/PubSub over JSON/WebSocket protocol."
4HOMEPAGE = "http://autobahn.ws/python"
5SECTION = "console/network"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = " file://autobahn/__init__.py;beginline=1;endline=17;md5=81964ceb3ab93bfb5e8cfbcd26f3af9c"
9
10SRC_URI = "https://pypi.python.org/packages/source/a/autobahn/autobahn-${PV}.zip"
11SRC_URI[md5sum] = "e2c80ba3e46428b32837537609d4d582"
12
13S = "${WORKDIR}/autobahn-${PV}"
14
15inherit setuptools
16
17RDEPENDS_${PN} = "python python-pprint python-twisted-protocols python-netserver python-twisted-web"
18