summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
new file mode 100644
index 000000000..58507442a
--- /dev/null
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.6.0.1.bb
@@ -0,0 +1,90 @@
1SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \
3efficient yet extensible format. Google uses Protocol Buffers for almost \
4all of its internal RPC protocols and file formats."
5HOMEPAGE = "https://github.com/google/protobuf"
6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
9
10DEPENDS = "zlib"
11DEPENDS_append_class-target = " protobuf-native"
12
13PV .= "+git${SRCPV}"
14
15SRCREV = "ce044817c7ba0aea27c3fd8e496635d94d20a755"
16
17SRC_URI = "git://github.com/google/protobuf.git;branch=3.6.x \
18 file://run-ptest \
19 file://0001-protobuf-fix-configure-error.patch \
20"
21S = "${WORKDIR}/git"
22
23inherit autotools-brokensep pkgconfig ptest
24
25EXTRA_OECONF += "--with-protoc=echo"
26
27TEST_SRC_DIR = "examples"
28LANG_SUPPORT = "cpp python"
29
30do_compile_ptest() {
31 # Modify makefile to use the cross-compiler
32 sed -e "s|c++|${CXX} \$(LDFLAGS)|g" -i "${S}/${TEST_SRC_DIR}/Makefile"
33
34 mkdir -p "${B}/${TEST_SRC_DIR}"
35
36 # Add the location of the cross-compiled header and library files
37 # which haven't been installed yet.
38 cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc"
39 sed -e 's|libdir=|libdir=${PKG_CONFIG_SYSROOT_DIR}|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
40 sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
41 sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
42 export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}"
43
44 # Save the pkgcfg sysroot variable, and update it to nothing so
45 # that it doesn't append the sysroot to the beginning of paths.
46 # The header and library files aren't installed to the target
47 # system yet. So the absolute paths were specified above.
48 save_pkg_config_sysroot_dir=$PKG_CONFIG_SYSROOT_DIR
49 export PKG_CONFIG_SYSROOT_DIR=
50
51 # Compile the tests
52 for lang in ${LANG_SUPPORT}; do
53 oe_runmake -C "${S}/${TEST_SRC_DIR}" ${lang}
54 done
55
56 # Restore the pkgconfig sysroot variable
57 export PKG_CONFIG_SYSROOT_DIR=$save_pkg_config_sysroot_dir
58}
59
60do_install_ptest() {
61 local olddir=`pwd`
62
63 cd "${S}/${TEST_SRC_DIR}"
64 install -d "${D}/${PTEST_PATH}"
65 for i in add_person* list_people*; do
66 if [ -x "$i" ]; then
67 install "$i" "${D}/${PTEST_PATH}"
68 fi
69 done
70 cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}"
71 cd "$olddir"
72}
73
74PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
75
76FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
77FILES_${PN}-lite = "${libdir}/libprotobuf-lite${SOLIBS}"
78
79RDEPENDS_${PN}-compiler = "${PN}"
80RDEPENDS_${PN}-dev += "${PN}-compiler"
81RDEPENDS_${PN}-ptest = "bash python-protobuf"
82
83MIPS_INSTRUCTION_SET = "mips"
84
85BBCLASSEXTEND = "native nativesdk"
86
87LDFLAGS_append_arm = " -latomic"
88LDFLAGS_append_mips = " -latomic"
89LDFLAGS_append_powerpc = " -latomic"
90LDFLAGS_append_mipsel = " -latomic"