summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php/php-m4-divert.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/php/php/php-m4-divert.patch')
-rw-r--r--meta-oe/recipes-devtools/php/php/php-m4-divert.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php/php-m4-divert.patch b/meta-oe/recipes-devtools/php/php/php-m4-divert.patch
new file mode 100644
index 000000000..dfc7b643e
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/php-m4-divert.patch
@@ -0,0 +1,83 @@
1Patch taken from
2
3http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
4
5diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
6--- php-5.2.10.org/configure.in 2009-06-17 14:22:41.000000000 +0200
7+++ php-5.2.10/configure.in 2009-08-18 12:16:25.317640253 +0200
8@@ -1,7 +1,7 @@
9 ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
10 dnl ## Process this file with autoconf to produce a configure script.
11
12-divert(1)
13+divert(1001)
14
15 dnl ## Diversion 1 is the autoconf + automake setup phase. We also
16 dnl ## set the PHP version, deal with platform-specific compile
17@@ -263,7 +263,7 @@
18 sinclude(TSRM/tsrm.m4)
19
20
21-divert(2)
22+divert(1002)
23
24 dnl ## Diversion 2 is where we set PHP-specific options and come up
25 dnl ## with reasonable default values for them. We check for pthreads here
26@@ -302,7 +302,7 @@
27 PTHREADS_FLAGS
28 fi
29
30-divert(3)
31+divert(1003)
32
33 dnl ## In diversion 3 we check for compile-time options to the PHP
34 dnl ## core and how to deal with different system dependencies.
35@@ -661,7 +661,7 @@
36 PHP_CRYPT_R_STYLE
37 fi
38
39-divert(4)
40+divert(1004)
41
42 dnl ## In diversion 4 we check user-configurable general settings.
43
44@@ -902,7 +902,7 @@
45 AC_MSG_RESULT([using system default])
46 fi
47
48-divert(5)
49+divert(1005)
50
51 dnl ## In diversion 5 we check which extensions should be compiled.
52 dnl ## All of these are normally in the extension directories.
53diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
54--- php-5.2.10.org/ext/standard/config.m4 2007-07-11 13:56:03.000000000 +0200
55+++ php-5.2.10/ext/standard/config.m4 2009-08-18 12:16:25.317640253 +0200
56@@ -1,6 +1,6 @@
57 dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
58
59-divert(3)dnl
60+divert(1003)dnl
61
62 dnl
63 dnl Check if flush should be called explicitly after buffered io
64@@ -205,7 +205,7 @@
65 AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
66 AC_FUNC_FNMATCH
67
68-divert(5)dnl
69+divert(1005)dnl
70
71 dnl
72 dnl Check for regex library type
73diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
74--- php-5.2.10.org/scripts/phpize.m4 2009-06-02 21:54:22.000000000 +0200
75+++ php-5.2.10/scripts/phpize.m4 2009-08-18 12:16:25.317640253 +0200
76@@ -1,6 +1,6 @@
77 dnl This file becomes configure.in for self-contained extensions.
78
79-divert(1)
80+divert(1001)
81
82 AC_PREREQ(2.13)
83 AC_INIT(config.m4)