summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php-7.1.7
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/php/php-7.1.7')
-rw-r--r--meta-oe/recipes-devtools/php/php-7.1.7/0001-Specify-tag-with-libtool.patch62
-rw-r--r--meta-oe/recipes-devtools/php/php-7.1.7/change-AC_TRY_RUN-to-AC_TRY_LINK.patch56
2 files changed, 118 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php-7.1.7/0001-Specify-tag-with-libtool.patch b/meta-oe/recipes-devtools/php/php-7.1.7/0001-Specify-tag-with-libtool.patch
new file mode 100644
index 000000000..18b4937db
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php-7.1.7/0001-Specify-tag-with-libtool.patch
@@ -0,0 +1,62 @@
1From 5c84b039e97abd88f6a18da0e6d27383c00fea92 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 26 Jul 2017 23:06:56 -0700
4Subject: [PATCH] Specify --tag with libtool
5
6This helps in compiling with external toolchains
7with -fPIE appended to CC e.g. via hardening flags
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 acinclude.m4 | 8 ++++----
12 configure.in | 4 ++--
13 2 files changed, 6 insertions(+), 6 deletions(-)
14
15diff --git a/acinclude.m4 b/acinclude.m4
16index a114a98..1cc7a26 100644
17--- a/acinclude.m4
18+++ b/acinclude.m4
19@@ -806,10 +806,10 @@ dnl
20 dnl PHP_BUILD_PROGRAM
21 dnl
22 AC_DEFUN([PHP_BUILD_PROGRAM],[
23- php_c_pre='$(LIBTOOL) --mode=compile $(CC)'
24+ php_c_pre='$(LIBTOOL) --tag=CC --mode=compile $(CC)'
25 php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
26 php_c_post=
27- php_cxx_pre='$(LIBTOOL) --mode=compile $(CXX)'
28+ php_cxx_pre='$(LIBTOOL) --tag=CXX --mode=compile $(CXX)'
29 php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
30 php_cxx_post=
31 php_lo=lo
32@@ -819,10 +819,10 @@ AC_DEFUN([PHP_BUILD_PROGRAM],[
33 no) pic_setting='-prefer-non-pic';;
34 esac
35
36- shared_c_pre='$(LIBTOOL) --mode=compile $(CC)'
37+ shared_c_pre='$(LIBTOOL) --tag=CC --mode=compile $(CC)'
38 shared_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS) '$pic_setting
39 shared_c_post=
40- shared_cxx_pre='$(LIBTOOL) --mode=compile $(CXX)'
41+ shared_cxx_pre='$(LIBTOOL) --tag=CXX --mode=compile $(CXX)'
42 shared_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS) '$pic_setting
43 shared_cxx_post=
44 shared_lo=lo
45diff --git a/configure.in b/configure.in
46index 7d65b63..7221af9 100644
47--- a/configure.in
48+++ b/configure.in
49@@ -1431,8 +1431,8 @@ PHP_SET_LIBTOOL_VARIABLE([--silent])
50 dnl libtool 1.4.3 needs this.
51 PHP_SET_LIBTOOL_VARIABLE([--preserve-dup-deps])
52
53-test -z "$PHP_COMPILE" && PHP_COMPILE='$(LIBTOOL) --mode=compile $(COMPILE) -c $<'
54-test -z "$CXX_PHP_COMPILE" && CXX_PHP_COMPILE='$(LIBTOOL) --mode=compile $(CXX_COMPILE) -c $<'
55+test -z "$PHP_COMPILE" && PHP_COMPILE='$(LIBTOOL) --tag=CC --mode=compile $(COMPILE) -c $<'
56+test -z "$CXX_PHP_COMPILE" && CXX_PHP_COMPILE='$(LIBTOOL) --tag=CXX --mode=compile $(CXX_COMPILE) -c $<'
57 SHARED_LIBTOOL='$(LIBTOOL)'
58
59 CC=$old_CC
60--
612.13.3
62
diff --git a/meta-oe/recipes-devtools/php/php-7.1.7/change-AC_TRY_RUN-to-AC_TRY_LINK.patch b/meta-oe/recipes-devtools/php/php-7.1.7/change-AC_TRY_RUN-to-AC_TRY_LINK.patch
new file mode 100644
index 000000000..39c334f39
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php-7.1.7/change-AC_TRY_RUN-to-AC_TRY_LINK.patch
@@ -0,0 +1,56 @@
1[PATCH] config.m4: change AC_TRY_RUN to AC_TRY_LINK
2
3Upstream-Status: Pending
4
5AC_TRY_RUN is not suitable for cross-compile
6
7Signed-off-by: Roy Li <rongqing.li@windriver.com>
8---
9 ext/fileinfo/config.m4 | 31 ++++++-------------------------
10 1 file changed, 6 insertions(+), 25 deletions(-)
11
12diff --git a/ext/fileinfo/config.m4 b/ext/fileinfo/config.m4
13index 7e98d62..8a8ea0e 100644
14--- a/ext/fileinfo/config.m4
15+++ b/ext/fileinfo/config.m4
16@@ -14,31 +14,12 @@ if test "$PHP_FILEINFO" != "no"; then
17 libmagic/readcdf.c libmagic/softmagic.c"
18
19 AC_MSG_CHECKING([for strcasestr])
20- AC_TRY_RUN([
21-#include <string.h>
22-#include <strings.h>
23-#include <stdlib.h>
24-
25-int main(void)
26-{
27- char *s0, *s1, *ret;
28-
29- s0 = (char *) malloc(42);
30- s1 = (char *) malloc(8);
31-
32- memset(s0, 'X', 42);
33- s0[24] = 'Y';
34- s0[26] = 'Z';
35- s0[41] = '\0';
36- memset(s1, 'x', 8);
37- s1[0] = 'y';
38- s1[2] = 'Z';
39- s1[7] = '\0';
40-
41- ret = strcasestr(s0, s1);
42-
43- return !(NULL != ret);
44-}
45+ AC_TRY_COMPILE([
46+ #include <string.h>
47+ #include <strings.h>
48+ #include <stdlib.h>
49+ ],[
50+ strcasestr(NULL, NULL);
51 ],[
52 dnl using the platform implementation
53 AC_MSG_RESULT(yes)
54--
551.9.1
56