summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb')
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
new file mode 100644
index 000000000..24a1245fc
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.641.bb
@@ -0,0 +1,36 @@
1SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10RDEPENDS_${PN} = " perl-module-carp \
11 perl-module-exporter \
12 perl-module-exporter-heavy \
13 perl-module-dynaloader \
14"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
19SRC_URI[md5sum] = "e77fd37fcf77fc88fde029c1b75ded54"
20SRC_URI[sha256sum] = "5509e532cdd0e3d91eda550578deaac29e2f008a12b64576e8c261bb92e8c2c1"
21
22S = "${WORKDIR}/DBI-${PV}"
23
24inherit cpan ptest-perl
25
26do_install_prepend() {
27 # test requires "-T" (taint) command line option
28 rm -rf ${B}/t/pod-coverage.t
29 rm -rf ${B}/t/13taint.t
30 # source of test failure not obvious
31 rm -rf ${B}/t/85gofer.t
32 # unclear why there are several duplicates of tests in tarball
33 rm -rf ${B}/t/z*.t
34}
35
36BBCLASSEXTEND = "native"