summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perfetto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/perfetto')
-rw-r--r--meta-oe/recipes-devtools/perfetto/perfetto.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.bb b/meta-oe/recipes-devtools/perfetto/perfetto.bb
index 86ab18cac..d1980a009 100644
--- a/meta-oe/recipes-devtools/perfetto/perfetto.bb
+++ b/meta-oe/recipes-devtools/perfetto/perfetto.bb
@@ -100,12 +100,12 @@ do_configure () {
100 100
101 # If using the clang toolchain: use the clang host-side binaries built by Bitbake 101 # If using the clang toolchain: use the clang host-side binaries built by Bitbake
102 if [ "${TOOLCHAIN}" = "clang" ]; then 102 if [ "${TOOLCHAIN}" = "clang" ]; then
103 BB_CLANGXX="${BUILD_CXX} ${BUILD_LDFLAGS} ${TUNE_CCARGS}" 103 BB_CLANGXX="${BUILD_CXX} ${BUILD_LDFLAGS}"
104 BB_CLANG="${BUILD_CC} ${TUNE_CCARGS}" 104 BB_CLANG="${BUILD_CC}"
105 BB_LLVM_OBJCOPY="${RECIPE_SYSROOT_NATIVE}/usr/bin/llvm-objcopy" 105 BB_LLVM_OBJCOPY="${RECIPE_SYSROOT_NATIVE}/usr/bin/llvm-objcopy"
106 106
107 HOST_CLANGXX="${STAGING_DIR_NATIVE}/usr/bin/clang++ -stdlib=libc++ -rtlib=libgcc -unwindlib=libgcc ${TUNE_CCARGS}" 107 HOST_CLANGXX="${STAGING_DIR_NATIVE}/usr/bin/clang++ -stdlib=libc++ -rtlib=libgcc -unwindlib=libgcc"
108 HOST_CLANG="${STAGING_DIR_NATIVE}/usr/bin/clang ${TUNE_CCARGS}" 108 HOST_CLANG="${STAGING_DIR_NATIVE}/usr/bin/clang"
109 HOST_LLVM_OBJCOPY="${STAGING_DIR_NATIVE}/usr/bin/llvm-objcopy" 109 HOST_LLVM_OBJCOPY="${STAGING_DIR_NATIVE}/usr/bin/llvm-objcopy"
110 110
111 cd gcc_like_host 111 cd gcc_like_host