diff options
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_4.3.2.bb')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_4.3.2.bb | 84 |
1 files changed, 84 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_4.3.2.bb b/meta-oe/recipes-devtools/nodejs/nodejs_4.3.2.bb new file mode 100644 index 000000000..c58fad539 --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs_4.3.2.bb | |||
@@ -0,0 +1,84 @@ | |||
1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" | ||
2 | HOMEPAGE = "http://nodejs.org" | ||
3 | LICENSE = "MIT & BSD & Artistic-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=003f16759ef967194d594a5ac6490401" | ||
5 | |||
6 | DEPENDS = "openssl" | ||
7 | |||
8 | COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*" | ||
9 | COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*" | ||
10 | COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*" | ||
11 | |||
12 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \ | ||
13 | file://no-registry.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "03f1424a1cfd322b5ba89da507d4cf07" | ||
16 | SRC_URI[sha256sum] = "f0c5761a7e4f520ab8793cb2dcabbd7dfd7f5839ce4f2cf79d9d52d1c2da5bca" | ||
17 | |||
18 | S = "${WORKDIR}/node-v${PV}" | ||
19 | |||
20 | # v8 errors out if you have set CCACHE | ||
21 | CCACHE = "" | ||
22 | |||
23 | def map_nodejs_arch(a, d): | ||
24 | import re | ||
25 | |||
26 | if re.match('i.86$', a): return 'ia32' | ||
27 | elif re.match('x86_64$', a): return 'x64' | ||
28 | elif re.match('aarch64$', a): return 'arm64' | ||
29 | elif re.match('powerpc64$', a): return 'ppc64' | ||
30 | elif re.match('powerpc$', a): return 'ppc' | ||
31 | return a | ||
32 | |||
33 | ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)}" | ||
34 | GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' " | ||
35 | ARCHFLAGS ?= "" | ||
36 | |||
37 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi | ||
38 | do_configure () { | ||
39 | export LD="${CXX}" | ||
40 | GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES | ||
41 | # $TARGET_ARCH settings don't match --dest-cpu settings | ||
42 | ./configure --prefix=${prefix} --without-snapshot --shared-openssl \ | ||
43 | --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH', True), d)}" \ | ||
44 | --dest-os=linux \ | ||
45 | ${ARCHFLAGS} | ||
46 | } | ||
47 | |||
48 | do_compile () { | ||
49 | export LD="${CXX}" | ||
50 | oe_runmake BUILDTYPE=Release | ||
51 | } | ||
52 | |||
53 | do_install () { | ||
54 | oe_runmake install DESTDIR=${D} | ||
55 | } | ||
56 | |||
57 | do_install_append_class-native() { | ||
58 | # use node from PATH instead of absolute path to sysroot | ||
59 | # node-v0.10.25/tools/install.py is using: | ||
60 | # shebang = os.path.join(node_prefix, 'bin/node') | ||
61 | # update_shebang(link_path, shebang) | ||
62 | # and node_prefix can be very long path to bindir in native sysroot and | ||
63 | # when it exceeds 128 character shebang limit it's stripped to incorrect path | ||
64 | # and npm fails to execute like in this case with 133 characters show in log.do_install: | ||
65 | # updating shebang of /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/work/x86_64-linux/nodejs-native/0.10.15-r0/image/home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/npm to /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/node | ||
66 | # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js | ||
67 | # use sed on npm-cli.js because otherwise symlink is replaced with normal file and | ||
68 | # npm-cli.js continues to use old shebang | ||
69 | sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js | ||
70 | } | ||
71 | |||
72 | do_install_append_class-target() { | ||
73 | sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js | ||
74 | } | ||
75 | |||
76 | PACKAGES =+ "${PN}-npm" | ||
77 | FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm" | ||
78 | RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils" | ||
79 | |||
80 | PACKAGES =+ "${PN}-systemtap" | ||
81 | FILES_${PN}-systemtap = "${datadir}/systemtap" | ||
82 | |||
83 | |||
84 | BBCLASSEXTEND = "native" | ||