summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb185
1 files changed, 185 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb
new file mode 100644
index 000000000..bc289001c
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.16.1.bb
@@ -0,0 +1,185 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & ISC & BSD-2-Clause & BSD-3-Clause & Artistic-2.0 & Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0be148d0e7298c5c94f7501affafbce5"
5
6CVE_PRODUCT = "nodejs node.js"
7
8DEPENDS = "openssl file-replacement-native"
9DEPENDS:append:class-target = " qemu-native"
10DEPENDS:append:class-native = " c-ares-native"
11
12inherit pkgconfig python3native qemu ptest
13
14COMPATIBLE_MACHINE:armv4 = "(!.*armv4).*"
15COMPATIBLE_MACHINE:armv5 = "(!.*armv5).*"
16COMPATIBLE_MACHINE:mips64 = "(!.*mips64).*"
17
18COMPATIBLE_HOST:riscv64 = "null"
19COMPATIBLE_HOST:riscv32 = "null"
20COMPATIBLE_HOST:powerpc = "null"
21
22SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
23 file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
24 file://0004-v8-don-t-override-ARM-CFLAGS.patch \
25 file://big-endian.patch \
26 file://mips-less-memory.patch \
27 file://system-c-ares.patch \
28 file://0001-liftoff-Correct-function-signatures.patch \
29 file://0001-mips-Use-32bit-cast-for-operand-on-mips32.patch \
30 file://run-ptest \
31 "
32
33SRC_URI:append:class-target = " \
34 file://0001-Using-native-binaries.patch \
35 "
36SRC_URI:append:toolchain-clang:x86 = " \
37 file://libatomic.patch \
38 "
39SRC_URI:append:toolchain-clang:powerpc64le = " \
40 file://0001-ppc64-Do-not-use-mminimal-toc-with-clang.patch \
41 "
42SRC_URI[sha256sum] = "e8404f8c8d89fdfdf7e95bbbc6066bd0e571acba58f54492599b615fbeefe272"
43
44S = "${WORKDIR}/node-v${PV}"
45
46# v8 errors out if you have set CCACHE
47CCACHE = ""
48
49def map_nodejs_arch(a, d):
50 import re
51
52 if re.match('i.86$', a): return 'ia32'
53 elif re.match('x86_64$', a): return 'x64'
54 elif re.match('aarch64$', a): return 'arm64'
55 elif re.match('(powerpc64|powerpc64le|ppc64le)$', a): return 'ppc64'
56 elif re.match('powerpc$', a): return 'ppc'
57 return a
58
59ARCHFLAGS:arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)} \
60 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-arm-fpu=neon', \
61 bb.utils.contains('TUNE_FEATURES', 'vfpv3d16', '--with-arm-fpu=vfpv3-d16', \
62 bb.utils.contains('TUNE_FEATURES', 'vfpv3', '--with-arm-fpu=vfpv3', \
63 '--with-arm-fpu=vfp', d), d), d)}"
64ARCHFLAGS:append:mips = " --v8-lite-mode"
65ARCHFLAGS:append:mipsel = " --v8-lite-mode"
66ARCHFLAGS ?= ""
67
68PACKAGECONFIG ??= "ares brotli icu zlib"
69
70PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
71PACKAGECONFIG[brotli] = "--shared-brotli,,brotli"
72PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
73PACKAGECONFIG[libuv] = "--shared-libuv,,libuv"
74PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2"
75PACKAGECONFIG[shared] = "--shared"
76PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
77
78# We don't want to cross-compile during target compile,
79# and we need to use the right flags during host compile,
80# too.
81EXTRA_OEMAKE = "\
82 CC.host='${CC}' \
83 CFLAGS.host='${CPPFLAGS} ${CFLAGS}' \
84 CXX.host='${CXX}' \
85 CXXFLAGS.host='${CPPFLAGS} ${CXXFLAGS}' \
86 LDFLAGS.host='${LDFLAGS}' \
87 AR.host='${AR}' \
88 \
89 builddir_name=./ \
90"
91
92EXTRANATIVEPATH += "file-native"
93
94python prune_sources() {
95 import shutil
96
97 shutil.rmtree(d.getVar('S') + '/deps/openssl')
98 if 'ares' in d.getVar('PACKAGECONFIG'):
99 shutil.rmtree(d.getVar('S') + '/deps/cares')
100 if 'brotli' in d.getVar('PACKAGECONFIG'):
101 shutil.rmtree(d.getVar('S') + '/deps/brotli')
102 if 'libuv' in d.getVar('PACKAGECONFIG'):
103 shutil.rmtree(d.getVar('S') + '/deps/uv')
104 if 'nghttp2' in d.getVar('PACKAGECONFIG'):
105 shutil.rmtree(d.getVar('S') + '/deps/nghttp2')
106 if 'zlib' in d.getVar('PACKAGECONFIG'):
107 shutil.rmtree(d.getVar('S') + '/deps/zlib')
108}
109do_unpack[postfuncs] += "prune_sources"
110
111# V8's JIT infrastructure requires binaries such as mksnapshot and
112# mkpeephole to be run in the host during the build. However, these
113# binaries must have the same bit-width as the target (e.g. a x86_64
114# host targeting ARMv6 needs to produce a 32-bit binary). Instead of
115# depending on a third Yocto toolchain, we just build those binaries
116# for the target and run them on the host with QEMU.
117python do_create_v8_qemu_wrapper () {
118 """Creates a small wrapper that invokes QEMU to run some target V8 binaries
119 on the host."""
120 qemu_libdirs = [d.expand('${STAGING_DIR_HOST}${libdir}'),
121 d.expand('${STAGING_DIR_HOST}${base_libdir}')]
122 qemu_cmd = qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'),
123 qemu_libdirs)
124 wrapper_path = d.expand('${B}/v8-qemu-wrapper.sh')
125 with open(wrapper_path, 'w') as wrapper_file:
126 wrapper_file.write("""#!/bin/sh
127
128# This file has been generated automatically.
129# It invokes QEMU to run binaries built for the target in the host during the
130# build process.
131
132%s "$@"
133""" % qemu_cmd)
134 os.chmod(wrapper_path, 0o755)
135}
136
137do_create_v8_qemu_wrapper[dirs] = "${B}"
138addtask create_v8_qemu_wrapper after do_configure before do_compile
139
140LDFLAGS:append:x86 = " -latomic"
141
142CROSS_FLAGS = "--cross-compiling"
143CROSS_FLAGS:class-native = "--no-cross-compiling"
144
145# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
146do_configure () {
147 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
148 # $TARGET_ARCH settings don't match --dest-cpu settings
149 python3 configure.py --verbose --prefix=${prefix} \
150 --shared-openssl \
151 --without-dtrace \
152 --without-etw \
153 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
154 --dest-os=linux \
155 --libdir=${baselib} \
156 ${CROSS_FLAGS} \
157 ${ARCHFLAGS} \
158 ${PACKAGECONFIG_CONFARGS}
159}
160
161do_compile () {
162 install -D ${RECIPE_SYSROOT_NATIVE}/etc/ssl/openssl.cnf ${B}/deps/openssl/nodejs-openssl.cnf
163 install -D ${B}/v8-qemu-wrapper.sh ${B}/out/Release/v8-qemu-wrapper.sh
164 oe_runmake BUILDTYPE=Release
165}
166
167do_install () {
168 oe_runmake install DESTDIR=${D}
169}
170
171do_install_ptest () {
172 cp -r ${B}/out/Release/cctest ${D}${PTEST_PATH}/
173 cp -r ${B}/test ${D}${PTEST_PATH}
174 chown -R root:root ${D}${PTEST_PATH}
175}
176
177PACKAGES =+ "${PN}-npm"
178FILES:${PN}-npm = "${nonarch_libdir}/node_modules ${bindir}/npm ${bindir}/npx ${bindir}/corepack"
179RDEPENDS:${PN}-npm = "bash python3-core python3-shell python3-datetime \
180 python3-misc python3-multiprocessing"
181
182PACKAGES =+ "${PN}-systemtap"
183FILES:${PN}-systemtap = "${datadir}/systemtap"
184
185BBCLASSEXTEND = "native"