summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb
new file mode 100644
index 000000000..22e1384d4
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.12.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT && zlib"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d6237f3a840aef5b7880fb4e49eecfe5"
5
6DEPENDS = "openssl"
7
8SRC_URI = " \
9 http://nodejs.org/dist/node-v${PV}.tar.gz \
10 file://libev-cross-cc_${PV}.patch \
11"
12SRC_URI[md5sum] = "a6375eaa43db5356bf443e25b828ae16"
13SRC_URI[sha256sum] = "c01af05b933ad4d2ca39f63cac057f54f032a4d83cff8711e42650ccee24fce4"
14
15S = "${WORKDIR}/node-v${PV}"
16
17# v8 errors out if you have set CCACHE
18CCACHE = ""
19
20do_configure () {
21 sed -i -e 's:/usr/lib:${STAGING_LIBDIR}:g' wscript
22 sed -i -e 's:/usr/local/lib:${STAGING_LIBDIR}:g' wscript
23 ./configure --prefix=${prefix} --without-snapshot
24}
25
26do_compile () {
27 make
28}
29
30do_install () {
31 DESTDIR=${D} oe_runmake install
32}
33
34RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
35
36FILES_${PN} += "${libdir}/node/wafadmin"
37BBCLASSEXTEND = "native"