summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb')
-rw-r--r--meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
new file mode 100644
index 000000000..88e332032
--- /dev/null
+++ b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
@@ -0,0 +1,21 @@
1SUMMARY = "JSON C++ lib used to read and write json file."
2DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
3 and writer in C++. JSON (JavaScript Object Notation) is a \
4 lightweight data-interchange format. It is easy for humans to \
5 read and write. It is easy for machines to parse and generate."
6
7HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
8
9SECTION = "libs"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
13
14SRCREV = "ddabf50f72cf369bf652a95c4d9fe31a1865a781"
15SRC_URI = "git://github.com/open-source-parsers/jsoncpp"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF"