summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jq/jq_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/jq/jq_1.3.bb')
-rw-r--r--meta-oe/recipes-devtools/jq/jq_1.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq_1.3.bb b/meta-oe/recipes-devtools/jq/jq_1.3.bb
new file mode 100644
index 000000000..c58b47280
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/jq_1.3.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "http://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=244a1fb9cf472474a062d67069dec653"
11
12DEPENDS = "flex-native bison-native"
13
14SRC_URI = "http://stedolan.github.io/${BPN}/download/source/${BP}.tar.gz \
15 file://automake-once-fix.patch \
16"
17SRC_URI[md5sum] = "26081b05d22525eca5cbdd8f9f4db17d"
18SRC_URI[sha256sum] = "623f23c36abfc1d96d85020cf421b56f90a229d566f26a4a0d3e8536244bfed7"
19
20inherit autotools
21
22# Don't build documentation (generation requires ruby)
23EXTRA_OECONF = "--disable-docs"