summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch')
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch b/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch
new file mode 100644
index 000000000..c84a0a0ad
--- /dev/null
+++ b/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch
@@ -0,0 +1,35 @@
1Index: iptraf-3.0.0/src/Makefile
2===================================================================
3--- iptraf-3.0.0.orig/src/Makefile
4+++ iptraf-3.0.0/src/Makefile
5@@ -5,7 +5,7 @@
6 #
7 # Architecture determination string borrowed from the kernel makefile.
8 #
9-ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
10+ARCH ?= $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
11 -e s/arm.*/arm/ -e s/sa110/arm/)
12 PLATFORM = -DPLATFORM=\"$(shell uname -s)/$(ARCH)\"
13 VERNUMBER := $(shell cat version)
14@@ -17,7 +17,7 @@ VERSION = -DVERSION=\"$(VERNUMBER)\"
15 #
16 BINDIR = ../../iptraf-$(VERNUMBER).bin.$(ARCH)
17
18-CC = gcc
19+CC = $(CC)
20 LIBS = -L../support -ltextbox -lpanel -lncurses # in this order!
21
22 # comment this one out to omit debug code when done.
23@@ -31,10 +31,10 @@ PROF = #-pg
24 # options to be passed to the compiler. I don't believe they need to be
25 # modified (except for -m486 on non-Intel x86 platforms).
26
27-CFLAGS = -Wall #-O2 #-m486
28+CFLAGS ?= -Wall #-O2 #-m486
29 DIRS = -DWORKDIR=\"$(WORKDIR)\" \
30 -DLOGDIR=\"$(LOGDIR)\" -DEXECDIR=\"$(TARGET)\"
31-LDOPTS = #-static
32+LDOPTS ?= #-static
33
34 # you may want to change this to point to your ncurses include directory
35 # if the ncurses include files are not in the default location.