diff options
Diffstat (limited to 'meta-oe/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99305.patch')
-rw-r--r-- | meta-oe/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99305.patch | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99305.patch b/meta-oe/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99305.patch new file mode 100644 index 000000000..ed25334df --- /dev/null +++ b/meta-oe/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99305.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | 2009-09-02 Daniel Jacobowitz <dan@codesourcery.com> | ||
2 | |||
3 | libgcc/ | ||
4 | * shared-object.mk (c_flags-$(base)$(objext)): New. | ||
5 | ($(base)$(objext)): Use above. | ||
6 | ($(base)_s$(objext)): Likewise. | ||
7 | * static-object.mk (c_flags-$(base)$(objext)): New. | ||
8 | ($(base)$(objext)): Use above. | ||
9 | |||
10 | 2010-07-10 Yao Qi <yao@codesourcery.com> | ||
11 | |||
12 | Merge from Sourcery G++ 4.4: | ||
13 | |||
14 | 2009-05-28 Julian Brown <julian@codesourcery.com> | ||
15 | |||
16 | Merged from Sourcery G++ 4.3: | ||
17 | |||
18 | === modified file 'libgcc/shared-object.mk' | ||
19 | --- old/libgcc/shared-object.mk 2008-07-03 18:22:00 +0000 | ||
20 | +++ new/libgcc/shared-object.mk 2010-07-30 13:11:02 +0000 | ||
21 | @@ -8,11 +8,13 @@ | ||
22 | |||
23 | ifeq ($(suffix $o),.c) | ||
24 | |||
25 | +c_flags-$(base)$(objext) := $(c_flags) | ||
26 | $(base)$(objext): $o | ||
27 | - $(gcc_compile) $(c_flags) -c $< $(vis_hide) | ||
28 | + $(gcc_compile) $(c_flags-$@) -c $< $(vis_hide) | ||
29 | |||
30 | +c_flags-$(base)_s$(objext) := $(c_flags) | ||
31 | $(base)_s$(objext): $o | ||
32 | - $(gcc_s_compile) $(c_flags) -c $< | ||
33 | + $(gcc_s_compile) $(c_flags-$@) -c $< | ||
34 | |||
35 | else | ||
36 | |||
37 | |||
38 | === modified file 'libgcc/static-object.mk' | ||
39 | --- old/libgcc/static-object.mk 2007-01-04 04:22:37 +0000 | ||
40 | +++ new/libgcc/static-object.mk 2010-07-30 13:11:02 +0000 | ||
41 | @@ -8,8 +8,9 @@ | ||
42 | |||
43 | ifeq ($(suffix $o),.c) | ||
44 | |||
45 | +c_flags-$(base)$(objext) := $(c_flags) | ||
46 | $(base)$(objext): $o | ||
47 | - $(gcc_compile) $(c_flags) -c $< $(vis_hide) | ||
48 | + $(gcc_compile) $(c_flags-$@) -c $< $(vis_hide) | ||
49 | |||
50 | else | ||
51 | |||
52 | |||