diff options
Diffstat (limited to 'meta-oe/recipes-devtools/gcc/gcc-4.5/gcc-flags-for-build.patch')
-rw-r--r-- | meta-oe/recipes-devtools/gcc/gcc-4.5/gcc-flags-for-build.patch | 178 |
1 files changed, 178 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/gcc/gcc-4.5/gcc-flags-for-build.patch b/meta-oe/recipes-devtools/gcc/gcc-4.5/gcc-flags-for-build.patch new file mode 100644 index 000000000..51892855a --- /dev/null +++ b/meta-oe/recipes-devtools/gcc/gcc-4.5/gcc-flags-for-build.patch | |||
@@ -0,0 +1,178 @@ | |||
1 | Index: gcc-4.5/Makefile.def | ||
2 | =================================================================== | ||
3 | --- gcc-4.5.orig/Makefile.def | ||
4 | +++ gcc-4.5/Makefile.def | ||
5 | @@ -240,6 +240,7 @@ flags_to_pass = { flag= AWK ; }; | ||
6 | flags_to_pass = { flag= BISON ; }; | ||
7 | flags_to_pass = { flag= CC_FOR_BUILD ; }; | ||
8 | flags_to_pass = { flag= CFLAGS_FOR_BUILD ; }; | ||
9 | +flags_to_pass = { flag= CPPFLAGS_FOR_BUILD ; }; | ||
10 | flags_to_pass = { flag= CXX_FOR_BUILD ; }; | ||
11 | flags_to_pass = { flag= EXPECT ; }; | ||
12 | flags_to_pass = { flag= FLEX ; }; | ||
13 | Index: gcc-4.5/gcc/Makefile.in | ||
14 | =================================================================== | ||
15 | --- gcc-4.5.orig/gcc/Makefile.in | ||
16 | +++ gcc-4.5/gcc/Makefile.in | ||
17 | @@ -766,7 +766,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS) | ||
18 | |||
19 | # Native linker and preprocessor flags. For x-fragment overrides. | ||
20 | BUILD_LDFLAGS=@BUILD_LDFLAGS@ | ||
21 | -BUILD_CPPFLAGS=$(ALL_CPPFLAGS) | ||
22 | +BUILD_CPPFLAGS=$(INCLUDES) @BUILD_CPPFLAGS@ $(X_CPPFLAGS) | ||
23 | |||
24 | # Actual name to use when installing a native compiler. | ||
25 | GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)') | ||
26 | Index: gcc-4.5/gcc/configure.ac | ||
27 | =================================================================== | ||
28 | --- gcc-4.5.orig/gcc/configure.ac | ||
29 | +++ gcc-4.5/gcc/configure.ac | ||
30 | @@ -1798,16 +1798,18 @@ AC_SUBST(inhibit_libc) | ||
31 | # Also, we cannot run fixincludes. | ||
32 | |||
33 | # These are the normal (build=host) settings: | ||
34 | -CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD) | ||
35 | -BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS) | ||
36 | -BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS) | ||
37 | -STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC) | ||
38 | +CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD) | ||
39 | +BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS) | ||
40 | +BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS) | ||
41 | +BUILD_CPPFLAGS='$(ALL_CPPFLAGS)' AC_SUBST(BUILD_CPPFLAGS) | ||
42 | +STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC) | ||
43 | |||
44 | # And these apply if build != host, or we are generating coverage data | ||
45 | if test x$build != x$host || test "x$coverage_flags" != x | ||
46 | then | ||
47 | BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
48 | BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)' | ||
49 | + BUILD_CPPFLAGS='$(CPPFLAGS_FOR_BUILD)' | ||
50 | fi | ||
51 | |||
52 | # Expand extra_headers to include complete path. | ||
53 | Index: gcc-4.5/Makefile.in | ||
54 | =================================================================== | ||
55 | --- gcc-4.5.orig/Makefile.in | ||
56 | +++ gcc-4.5/Makefile.in | ||
57 | @@ -333,6 +333,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@ | ||
58 | AS_FOR_BUILD = @AS_FOR_BUILD@ | ||
59 | CC_FOR_BUILD = @CC_FOR_BUILD@ | ||
60 | CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@ | ||
61 | +CPPFLAGS_FOR_BUILD = @CPPFLAGS_FOR_BUILD@ | ||
62 | CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@ | ||
63 | CXX_FOR_BUILD = @CXX_FOR_BUILD@ | ||
64 | DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@ | ||
65 | @@ -662,6 +663,7 @@ BASE_FLAGS_TO_PASS = \ | ||
66 | "BISON=$(BISON)" \ | ||
67 | "CC_FOR_BUILD=$(CC_FOR_BUILD)" \ | ||
68 | "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \ | ||
69 | + "CPPFLAGS_FOR_BUILD=$(CPPFLAGS_FOR_BUILD)" \ | ||
70 | "CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \ | ||
71 | "EXPECT=$(EXPECT)" \ | ||
72 | "FLEX=$(FLEX)" \ | ||
73 | Index: gcc-4.5/gcc/configure | ||
74 | =================================================================== | ||
75 | --- gcc-4.5.orig/gcc/configure | ||
76 | +++ gcc-4.5/gcc/configure | ||
77 | @@ -707,6 +707,7 @@ SED | ||
78 | LIBTOOL | ||
79 | collect2 | ||
80 | STMP_FIXINC | ||
81 | +BUILD_CPPFLAGS | ||
82 | BUILD_LDFLAGS | ||
83 | BUILD_CFLAGS | ||
84 | CC_FOR_BUILD | ||
85 | @@ -10982,6 +10983,7 @@ fi | ||
86 | CC_FOR_BUILD='$(CC)' | ||
87 | BUILD_CFLAGS='$(ALL_CFLAGS)' | ||
88 | BUILD_LDFLAGS='$(LDFLAGS)' | ||
89 | +BUILD_CPPFLAGS='$(ALL_CPPFLAGS)' | ||
90 | STMP_FIXINC=stmp-fixinc | ||
91 | |||
92 | # And these apply if build != host, or we are generating coverage data | ||
93 | @@ -10989,6 +10991,7 @@ if test x$build != x$host || test "x$cov | ||
94 | then | ||
95 | BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
96 | BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)' | ||
97 | + BUILD_CPPFLAGS='$(CPPFLAGS_FOR_BUILD)' | ||
98 | fi | ||
99 | |||
100 | # Expand extra_headers to include complete path. | ||
101 | @@ -17108,7 +17111,7 @@ else | ||
102 | lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2 | ||
103 | lt_status=$lt_dlunknown | ||
104 | cat > conftest.$ac_ext <<_LT_EOF | ||
105 | -#line 17111 "configure" | ||
106 | +#line 17114 "configure" | ||
107 | #include "confdefs.h" | ||
108 | |||
109 | #if HAVE_DLFCN_H | ||
110 | @@ -17214,7 +17217,7 @@ else | ||
111 | lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2 | ||
112 | lt_status=$lt_dlunknown | ||
113 | cat > conftest.$ac_ext <<_LT_EOF | ||
114 | -#line 17217 "configure" | ||
115 | +#line 17220 "configure" | ||
116 | #include "confdefs.h" | ||
117 | |||
118 | #if HAVE_DLFCN_H | ||
119 | Index: gcc-4.5/Makefile.tpl | ||
120 | =================================================================== | ||
121 | --- gcc-4.5.orig/Makefile.tpl | ||
122 | +++ gcc-4.5/Makefile.tpl | ||
123 | @@ -336,6 +336,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@ | ||
124 | AS_FOR_BUILD = @AS_FOR_BUILD@ | ||
125 | CC_FOR_BUILD = @CC_FOR_BUILD@ | ||
126 | CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@ | ||
127 | +CPPFLAGS_FOR_BUILD = @CPPFLAGS_FOR_BUILD@ | ||
128 | CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@ | ||
129 | CXX_FOR_BUILD = @CXX_FOR_BUILD@ | ||
130 | DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@ | ||
131 | Index: gcc-4.5/configure | ||
132 | =================================================================== | ||
133 | --- gcc-4.5.orig/configure | ||
134 | +++ gcc-4.5/configure | ||
135 | @@ -651,6 +651,7 @@ GCJ_FOR_BUILD | ||
136 | DLLTOOL_FOR_BUILD | ||
137 | CXX_FOR_BUILD | ||
138 | CXXFLAGS_FOR_BUILD | ||
139 | +CPPFLAGS_FOR_BUILD | ||
140 | CFLAGS_FOR_BUILD | ||
141 | CC_FOR_BUILD | ||
142 | AS_FOR_BUILD | ||
143 | @@ -8036,6 +8037,7 @@ esac | ||
144 | # our build compiler if desired. | ||
145 | if test x"${build}" = x"${host}" ; then | ||
146 | CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}} | ||
147 | + CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}} | ||
148 | CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}} | ||
149 | LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}} | ||
150 | fi | ||
151 | @@ -8101,6 +8103,7 @@ done | ||
152 | |||
153 | |||
154 | |||
155 | + | ||
156 | |||
157 | |||
158 | |||
159 | Index: gcc-4.5/configure.ac | ||
160 | =================================================================== | ||
161 | --- gcc-4.5.orig/configure.ac | ||
162 | +++ gcc-4.5/configure.ac | ||
163 | @@ -3089,6 +3089,7 @@ esac | ||
164 | # our build compiler if desired. | ||
165 | if test x"${build}" = x"${host}" ; then | ||
166 | CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}} | ||
167 | + CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}} | ||
168 | CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}} | ||
169 | LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}} | ||
170 | fi | ||
171 | @@ -3155,6 +3156,7 @@ AC_SUBST(AR_FOR_BUILD) | ||
172 | AC_SUBST(AS_FOR_BUILD) | ||
173 | AC_SUBST(CC_FOR_BUILD) | ||
174 | AC_SUBST(CFLAGS_FOR_BUILD) | ||
175 | +AC_SUBST(CPPFLAGS_FOR_BUILD) | ||
176 | AC_SUBST(CXXFLAGS_FOR_BUILD) | ||
177 | AC_SUBST(CXX_FOR_BUILD) | ||
178 | AC_SUBST(DLLTOOL_FOR_BUILD) | ||