diff options
Diffstat (limited to 'meta-oe/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch')
-rw-r--r-- | meta-oe/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch b/meta-oe/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch new file mode 100644 index 000000000..45df47c5b --- /dev/null +++ b/meta-oe/recipes-devtools/gcc/gcc-4.5/Makefile.in.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | Index: gcc-4.5/gcc/Makefile.in | ||
2 | =================================================================== | ||
3 | --- gcc-4.5.orig/gcc/Makefile.in | ||
4 | +++ gcc-4.5/gcc/Makefile.in | ||
5 | @@ -656,7 +656,7 @@ LIBGCC2_INCLUDES = | ||
6 | TARGET_LIBGCC2_CFLAGS = | ||
7 | |||
8 | # Options to use when compiling crtbegin/end. | ||
9 | -CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(INCLUDES) $(MULTILIB_CFLAGS) -g0 \ | ||
10 | +CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(TARGET_INCLUDES) $(MULTILIB_CFLAGS) -g0 \ | ||
11 | -finhibit-size-directive -fno-inline -fno-exceptions \ | ||
12 | -fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \ | ||
13 | $(INHIBIT_LIBC_CFLAGS) | ||
14 | @@ -1038,10 +1038,14 @@ BUILD_ERRORS = build/errors.o | ||
15 | # -I$(@D) and -I$(srcdir)/$(@D) cause the subdirectory of the file | ||
16 | # currently being compiled, in both source trees, to be examined as well. | ||
17 | # libintl.h will be found in ../intl if we are using the included libintl. | ||
18 | -INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \ | ||
19 | +# | ||
20 | +# TARGET_INCLUDES is added to avoid that GMPINC (which points to the host | ||
21 | +# include dir) is used for compiling libgcc.a | ||
22 | +TARGET_INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \ | ||
23 | -I$(srcdir)/../include @INCINTL@ \ | ||
24 | - $(CPPINC) $(GMPINC) $(DECNUMINC) \ | ||
25 | + $(CPPINC) $(DECNUMINC) \ | ||
26 | $(PPLINC) $(CLOOGINC) $(LIBELFINC) | ||
27 | +INCLUDES = $(TARGET_INCLUDES) $(GMPINC) | ||
28 | |||
29 | .c.o: | ||
30 | $(COMPILER) -c $(ALL_COMPILERFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION) | ||