summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb')
-rw-r--r--meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb b/meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb
new file mode 100644
index 000000000..56462a913
--- /dev/null
+++ b/meta-oe/recipes-devtools/cpuid/cpuid_20200211.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
10 "
11SRC_URI[md5sum] = "c3dda40aee78bd187929f454a3c75f35"
12SRC_URI[sha256sum] = "a570ca23ce5543fb6974abcbbde0261ea7dbfea40f4e7335b4870274315e521b"
13
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16inherit perlnative
17
18# The install rule from the Makefile has hardcoded paths, so we duplicate
19# the actions to accommodate different paths.
20do_install () {
21 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
22 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
23}