diff options
Diffstat (limited to 'meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb')
-rw-r--r-- | meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb new file mode 100644 index 000000000..b0ff5cf45 --- /dev/null +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \ | ||
2 | safe memory reclamation mechanisms and non-blocking data structures \ | ||
3 | designed to aid in the design and implementation of high performance \ | ||
4 | concurrent systems." | ||
5 | |||
6 | LICENSE = "BSD & Apache-2.0" | ||
7 | HOMEPAGE = "http://concurrencykit.org" | ||
8 | SECTION = "base" | ||
9 | |||
10 | SRCREV = "900d203aa9e41288545368ea40da0bee89f7907f" | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f12611e65e064515ce264249b2bdea98" | ||
12 | SRC_URI = "git://git.concurrencykit.org/ck.git;protocol=git \ | ||
13 | file://cross.patch \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*" | ||
19 | |||
20 | inherit autotools | ||
21 | |||
22 | PLAT_powerpc64 = "ppc64" | ||
23 | PLAT ?= "${HOST_ARCH}" | ||
24 | |||
25 | do_configure () { | ||
26 | export PLATFORM=${PLAT} | ||
27 | export COMPILER='gcc' | ||
28 | ${S}/configure \ | ||
29 | --prefix=${prefix} \ | ||
30 | --includedir=${includedir} \ | ||
31 | --libdir=${libdir} \ | ||
32 | } | ||
33 | |||
34 | do_compile () { | ||
35 | oe_runmake | ||
36 | } | ||
37 | |||
38 | do_install () { | ||
39 | oe_runmake 'DESTDIR=${D}' install | ||
40 | } | ||