summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
new file mode 100644
index 000000000..b6d2da085
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Meet Cloud9, development-as-a-service for Javascripters and other developers"
2HOMEPAGE = "http://c9.io"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
5
6SRC_URI = "git://github.com/jadonk/cloud9.git;protocol=git \
7"
8
9SRCREV = "08bae1d1cc2ba9f7f883a25afd07f0339a82fa8b"
10S = "${WORKDIR}/git"
11
12# Most of cloud9 is in git submodules that still need to be fetched.
13do_configure_prepend () {
14 git submodule update --init --recursive
15}
16
17# There's nothing left to be compiled at this time.
18# node-o3-xml is the only compiled code module in here.
19# The repository has binaries for:
20# Linux ARM armv7
21# Linux x86 32/64-bit
22# Sun Solaris 32-bit
23# Mac x86 32/64-bit
24# Windows x86 32-bit
25do_compile () {
26:
27}
28
29do_install () {
30 install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
31 rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9
32 touch ${D}${bindir}/cloud9
33 echo "#!/bin/sh" > ${D}${bindir}/cloud9
34 echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
35 chmod 0755 ${D}${bindir}/cloud9
36}
37
38RDEPENDS_${PN} = "nodejs"
39