diff options
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb.inc | 4 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch | 170 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb) | 0 |
5 files changed, 1 insertions, 216 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb b/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb index 578357b48..578357b48 100644 --- a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb +++ b/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb | |||
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc index 32a6022ba..ae6581ec7 100644 --- a/meta-oe/recipes-dbs/mysql/mariadb.inc +++ b/meta-oe/recipes-dbs/mysql/mariadb.inc | |||
@@ -23,11 +23,9 @@ SRC_URI = "https://archive.mariadb.org/${BP}/source/${BP}.tar.gz \ | |||
23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ | 23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ |
24 | file://lfs64.patch \ | 24 | file://lfs64.patch \ |
25 | file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ | 25 | file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ |
26 | file://0001-Remove-the-compile_time_assert-lines.patch \ | ||
27 | file://0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch \ | ||
28 | " | 26 | " |
29 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" | 27 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" |
30 | SRC_URI[sha256sum] = "5239a245ed90517e96396605cd01ccd8f73cd7442d1b3076b6ffe258110e5157" | 28 | SRC_URI[sha256sum] = "0a00180864cd016187c986faab8010de23a117b9a75f91d6456421f894e48d20" |
31 | 29 | ||
32 | UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/tags" | 30 | UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/tags" |
33 | 31 | ||
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch deleted file mode 100644 index 3e42535da..000000000 --- a/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch +++ /dev/null | |||
@@ -1,170 +0,0 @@ | |||
1 | From dae52f5916ef59434c93f0b716270f59dd0c3a94 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jan Tojnar <jtojnar@gmail.com> | ||
3 | Date: Sun, 7 Jan 2024 10:19:54 +0100 | ||
4 | Subject: [PATCH] MDEV-33439 Fix build with libxml2 2.12 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | libxml2 2.12.0 made `xmlGetLastError()` return `const` pointer: | ||
10 | |||
11 | https://gitlab.gnome.org/GNOME/libxml2/-/commit/61034116d0a3c8b295c6137956adc3ae55720711 | ||
12 | |||
13 | Clang 16 does not like this: | ||
14 | |||
15 | error: assigning to 'xmlErrorPtr' (aka '_xmlError *') from 'const xmlError *' (aka 'const _xmlError *') discards qualifiers | ||
16 | error: cannot initialize a variable of type 'xmlErrorPtr' (aka '_xmlError *') with an rvalue of type 'const xmlError *' (aka 'const _xmlError *') | ||
17 | |||
18 | Let’s update the variables to `const`. | ||
19 | For older versions, it will be automatically converted. | ||
20 | |||
21 | But then `xmlResetError(xmlError*)` will not like the `const` pointer: | ||
22 | |||
23 | error: no matching function for call to 'xmlResetError' | ||
24 | note: candidate function not viable: 1st argument ('const xmlError *' (aka 'const _xmlError *')) would lose const qualifier | ||
25 | |||
26 | Let’s replace it with `xmlResetLastError()`. | ||
27 | |||
28 | ALso remove `LIBXMLDOC::Xerr` protected member property. | ||
29 | It was introduced in 65b0e5455b547a3d574fa77b34cce23ae3bea0a0 | ||
30 | along with the `xmlResetError` calls. | ||
31 | It does not appear to be used for anything. | ||
32 | |||
33 | Upstream-Status: Backport [https://github.com/MariaDB/server/pull/2983] | ||
34 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
35 | --- | ||
36 | storage/connect/libdoc.cpp | 39 +++++++++++++++++++------------------- | ||
37 | 1 file changed, 19 insertions(+), 20 deletions(-) | ||
38 | |||
39 | diff --git a/storage/connect/libdoc.cpp b/storage/connect/libdoc.cpp | ||
40 | index 67f22ce2..ab588dd4 100644 | ||
41 | --- a/storage/connect/libdoc.cpp | ||
42 | +++ b/storage/connect/libdoc.cpp | ||
43 | @@ -93,7 +93,6 @@ class LIBXMLDOC : public XMLDOCUMENT { | ||
44 | xmlXPathContextPtr Ctxp; | ||
45 | xmlXPathObjectPtr Xop; | ||
46 | xmlXPathObjectPtr NlXop; | ||
47 | - xmlErrorPtr Xerr; | ||
48 | char *Buf; // Temporary | ||
49 | bool Nofreelist; | ||
50 | }; // end of class LIBXMLDOC | ||
51 | @@ -327,7 +326,6 @@ LIBXMLDOC::LIBXMLDOC(char *nsl, char *nsdf, char *enc, PFBLOCK fp) | ||
52 | Ctxp = NULL; | ||
53 | Xop = NULL; | ||
54 | NlXop = NULL; | ||
55 | - Xerr = NULL; | ||
56 | Buf = NULL; | ||
57 | Nofreelist = false; | ||
58 | } // end of LIBXMLDOC constructor | ||
59 | @@ -365,8 +363,8 @@ bool LIBXMLDOC::ParseFile(PGLOBAL g, char *fn) | ||
60 | Encoding = (char*)Docp->encoding; | ||
61 | |||
62 | return false; | ||
63 | - } else if ((Xerr = xmlGetLastError())) | ||
64 | - xmlResetError(Xerr); | ||
65 | + } else if (xmlGetLastError()) | ||
66 | + xmlResetLastError(); | ||
67 | |||
68 | return true; | ||
69 | } // end of ParseFile | ||
70 | @@ -505,9 +503,9 @@ int LIBXMLDOC::DumpDoc(PGLOBAL g, char *ofn) | ||
71 | #if 1 | ||
72 | // This function does not crash ( | ||
73 | if (xmlSaveFormatFileEnc((const char *)ofn, Docp, Encoding, 0) < 0) { | ||
74 | - xmlErrorPtr err = xmlGetLastError(); | ||
75 | + const xmlError *err = xmlGetLastError(); | ||
76 | strcpy(g->Message, (err) ? err->message : "Error saving XML doc"); | ||
77 | - xmlResetError(Xerr); | ||
78 | + xmlResetLastError(); | ||
79 | rc = -1; | ||
80 | } // endif Save | ||
81 | // rc = xmlDocDump(of, Docp); | ||
82 | @@ -546,8 +544,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp) | ||
83 | if (Nlist) { | ||
84 | xmlXPathFreeNodeSet(Nlist); | ||
85 | |||
86 | - if ((Xerr = xmlGetLastError())) | ||
87 | - xmlResetError(Xerr); | ||
88 | + if (xmlGetLastError()) | ||
89 | + xmlResetLastError(); | ||
90 | |||
91 | Nlist = NULL; | ||
92 | } // endif Nlist | ||
93 | @@ -555,8 +553,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp) | ||
94 | if (Xop) { | ||
95 | xmlXPathFreeObject(Xop); | ||
96 | |||
97 | - if ((Xerr = xmlGetLastError())) | ||
98 | - xmlResetError(Xerr); | ||
99 | + if (xmlGetLastError()) | ||
100 | + xmlResetLastError(); | ||
101 | |||
102 | Xop = NULL; | ||
103 | } // endif Xop | ||
104 | @@ -564,8 +562,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp) | ||
105 | if (NlXop) { | ||
106 | xmlXPathFreeObject(NlXop); | ||
107 | |||
108 | - if ((Xerr = xmlGetLastError())) | ||
109 | - xmlResetError(Xerr); | ||
110 | + if (xmlGetLastError()) | ||
111 | + xmlResetLastError(); | ||
112 | |||
113 | NlXop = NULL; | ||
114 | } // endif NlXop | ||
115 | @@ -573,8 +571,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp) | ||
116 | if (Ctxp) { | ||
117 | xmlXPathFreeContext(Ctxp); | ||
118 | |||
119 | - if ((Xerr = xmlGetLastError())) | ||
120 | - xmlResetError(Xerr); | ||
121 | + if (xmlGetLastError()) | ||
122 | + xmlResetLastError(); | ||
123 | |||
124 | Ctxp = NULL; | ||
125 | } // endif Ctxp | ||
126 | @@ -590,6 +588,7 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp) | ||
127 | /******************************************************************/ | ||
128 | xmlNodeSetPtr LIBXMLDOC::GetNodeList(PGLOBAL g, xmlNodePtr np, char *xp) | ||
129 | { | ||
130 | + const xmlError *xerr; | ||
131 | xmlNodeSetPtr nl; | ||
132 | |||
133 | if (trace(1)) | ||
134 | @@ -649,11 +648,11 @@ xmlNodeSetPtr LIBXMLDOC::GetNodeList(PGLOBAL g, xmlNodePtr np, char *xp) | ||
135 | } else | ||
136 | xmlXPathFreeObject(Xop); // Caused node not found | ||
137 | |||
138 | - if ((Xerr = xmlGetLastError())) { | ||
139 | - strcpy(g->Message, Xerr->message); | ||
140 | - xmlResetError(Xerr); | ||
141 | + if ((xerr = xmlGetLastError())) { | ||
142 | + strcpy(g->Message, xerr->message); | ||
143 | + xmlResetLastError(); | ||
144 | return NULL; | ||
145 | - } // endif Xerr | ||
146 | + } // endif xerr | ||
147 | |||
148 | } // endif Xop | ||
149 | |||
150 | @@ -1079,7 +1078,7 @@ void XML2NODE::AddText(PGLOBAL g, PCSZ txtp) | ||
151 | /******************************************************************/ | ||
152 | void XML2NODE::DeleteChild(PGLOBAL g, PXNODE dnp) | ||
153 | { | ||
154 | - xmlErrorPtr xerr; | ||
155 | + const xmlError *xerr; | ||
156 | |||
157 | if (trace(1)) | ||
158 | htrc("DeleteChild: node=%p\n", dnp); | ||
159 | @@ -1122,7 +1121,7 @@ void XML2NODE::DeleteChild(PGLOBAL g, PXNODE dnp) | ||
160 | if (trace(1)) | ||
161 | htrc("DeleteChild: errmsg=%-.256s\n", xerr->message); | ||
162 | |||
163 | - xmlResetError(xerr); | ||
164 | + xmlResetLastError(); | ||
165 | } // end of DeleteChild | ||
166 | |||
167 | /* -------------------- class XML2NODELIST ---------------------- */ | ||
168 | -- | ||
169 | 2.44.0 | ||
170 | |||
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch deleted file mode 100644 index 9a6e28297..000000000 --- a/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From cc5f1d0759b367265a1a000287e2ec15c31eb518 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Mon, 26 Feb 2024 14:56:02 +0800 | ||
4 | Subject: [PATCH] Remove the compile_time_assert lines | ||
5 | |||
6 | Remove the problematic compile_time_assert lines to fix the below build | ||
7 | failure on 32-bit arm. | ||
8 | In file included from TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/mariadb/10.11.7/mariadb-10.11.7/tests/mysql_client_test.c:38: | ||
9 | TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/mariadb/10.11.7/mariadb-10.11.7/tests/mysql_client_fw.c:1438:3: error: 'compile_time_assert' declared as an array with a negative size | ||
10 | 1438 | compile_time_assert(sizeof(MYSQL) == 77*sizeof(void*)+656); | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
12 | |||
13 | Upstream-Status: Inappropriate [Upstream will bring the asset back | ||
14 | in a new way [1]] | ||
15 | [1] https://jira.mariadb.org/browse/MDEV-33429 | ||
16 | |||
17 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
18 | --- | ||
19 | tests/mysql_client_fw.c | 8 -------- | ||
20 | 1 file changed, 8 deletions(-) | ||
21 | |||
22 | diff --git a/tests/mysql_client_fw.c b/tests/mysql_client_fw.c | ||
23 | index c9e64678..5c0c7ce2 100644 | ||
24 | --- a/tests/mysql_client_fw.c | ||
25 | +++ b/tests/mysql_client_fw.c | ||
26 | @@ -1430,14 +1430,6 @@ int main(int argc, char **argv) | ||
27 | tests_to_run[i]= NULL; | ||
28 | } | ||
29 | |||
30 | -#ifdef _WIN32 | ||
31 | - /* must be the same in C/C and embedded, 1208 on 64bit, 968 on 32bit */ | ||
32 | - compile_time_assert(sizeof(MYSQL) == 60*sizeof(void*)+728); | ||
33 | -#else | ||
34 | - /* must be the same in C/C and embedded, 1272 on 64bit, 964 on 32bit */ | ||
35 | - compile_time_assert(sizeof(MYSQL) == 77*sizeof(void*)+656); | ||
36 | -#endif | ||
37 | - | ||
38 | if (mysql_server_init(embedded_server_arg_count, | ||
39 | embedded_server_args, | ||
40 | (char**) embedded_server_groups)) | ||
41 | -- | ||
42 | 2.25.1 | ||
43 | |||
diff --git a/meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb b/meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb index b1d1355e2..b1d1355e2 100644 --- a/meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb +++ b/meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb | |||