summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb11
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb.inc13
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch2
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch2
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc10
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb (renamed from meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb)2
-rw-r--r--meta-oe/recipes-dbs/soci/soci_4.0.3.bb17
7 files changed, 28 insertions, 29 deletions
diff --git a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
index 530107151..9506d0e55 100644
--- a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
+++ b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
@@ -38,19 +38,20 @@ USERADD_PACKAGES = "${PN}"
38USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb" 38USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb"
39 39
40do_install:prepend() { 40do_install:prepend() {
41 rm ${B}/src/${GO_IMPORT}/build.py 41 test -e ${B}/src/${GO_IMPORT}/build.py && rm ${B}/src/${GO_IMPORT}/build.py
42 rm ${B}/src/${GO_IMPORT}/build.sh 42 test -e ${B}/src/${GO_IMPORT}/build.sh && rm ${B}/src/${GO_IMPORT}/build.sh
43 rm ${B}/src/${GO_IMPORT}/Dockerfile* 43 rm -rf ${B}/src/${GO_IMPORT}/Dockerfile*
44
44 sed -i -e "s#usr/bin/sh#bin/sh#g" ${B}/src/${GO_IMPORT}/scripts/ci/run_perftest.sh 45 sed -i -e "s#usr/bin/sh#bin/sh#g" ${B}/src/${GO_IMPORT}/scripts/ci/run_perftest.sh
45} 46}
46 47
47do_install:append() { 48do_install:append() {
48 install -d ${D}${sysconfdir}/influxdb 49 install -d ${D}${sysconfdir}/influxdb
49 install -m 0644 ${WORKDIR}/influxdb.conf ${D}${sysconfdir}/influxdb 50 install -m 0644 ${UNPACKDIR}/influxdb.conf ${D}${sysconfdir}/influxdb
50 chown -R root:influxdb ${D}${sysconfdir}/influxdb 51 chown -R root:influxdb ${D}${sysconfdir}/influxdb
51 52
52 install -d ${D}${sysconfdir}/init.d 53 install -d ${D}${sysconfdir}/init.d
53 install -m 0755 ${WORKDIR}/influxdb ${D}${sysconfdir}/init.d/influxdb 54 install -m 0755 ${UNPACKDIR}/influxdb ${D}${sysconfdir}/init.d/influxdb
54 55
55 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ] ; then 56 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ] ; then
56 install -d ${D}${sysconfdir}/logrotate.d 57 install -d ${D}${sysconfdir}/logrotate.d
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc
index 33da32fb2..695965f7d 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb.inc
+++ b/meta-oe/recipes-dbs/mysql/mariadb.inc
@@ -31,8 +31,6 @@ SRC_URI[sha256sum] = "5239a245ed90517e96396605cd01ccd8f73cd7442d1b3076b6ffe25811
31 31
32UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/releases" 32UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/releases"
33 33
34S = "${WORKDIR}/mariadb-${PV}"
35
36BINCONFIG_GLOB = "mysql_config" 34BINCONFIG_GLOB = "mysql_config"
37 35
38inherit cmake gettext binconfig update-rc.d systemd multilib_script pkgconfig 36inherit cmake gettext binconfig update-rc.d systemd multilib_script pkgconfig
@@ -80,6 +78,7 @@ BUILD_CFLAGS += "-fuse-ld=bfd"
80BUILD_CXXFLAGS += "-fuse-ld=bfd" 78BUILD_CXXFLAGS += "-fuse-ld=bfd"
81 79
82LDFLAGS:x86:toolchain-clang = "-latomic" 80LDFLAGS:x86:toolchain-clang = "-latomic"
81LDFLAGS:riscv32:toolchain-clang = "-latomic"
83 82
84EXTRA_OECMAKE = "-DWITH_EMBEDDED_SERVER=ON \ 83EXTRA_OECMAKE = "-DWITH_EMBEDDED_SERVER=ON \
85 -DWITH_JEMALLOC=no \ 84 -DWITH_JEMALLOC=no \
@@ -163,18 +162,18 @@ do_install() {
163 oe_runmake 'DESTDIR=${D}' install 162 oe_runmake 'DESTDIR=${D}' install
164 163
165 install -d ${D}/${sysconfdir}/init.d 164 install -d ${D}/${sysconfdir}/init.d
166 install -m 0644 ${WORKDIR}/my.cnf ${D}/${sysconfdir}/ 165 install -m 0644 ${UNPACKDIR}/my.cnf ${D}/${sysconfdir}/
167 install -m 0755 ${WORKDIR}/install_db ${D}/${sysconfdir}/init.d/ 166 install -m 0755 ${UNPACKDIR}/install_db ${D}/${sysconfdir}/init.d/
168 mv ${D}/${sysconfdir}/init.d/mysql ${D}/${sysconfdir}/init.d/mysqld 167 mv ${D}/${sysconfdir}/init.d/mysql ${D}/${sysconfdir}/init.d/mysqld
169 168
170 install -d ${D}${systemd_unitdir}/system 169 install -d ${D}${systemd_unitdir}/system
171 install -m 0644 ${WORKDIR}/mysqld.service ${D}${systemd_unitdir}/system 170 install -m 0644 ${UNPACKDIR}/mysqld.service ${D}${systemd_unitdir}/system
172 install -m 0644 ${WORKDIR}/install_db.service ${D}${systemd_unitdir}/system 171 install -m 0644 ${UNPACKDIR}/install_db.service ${D}${systemd_unitdir}/system
173 sed -i -e 's,@BINDIR@,${bindir},g' -e 's,@PREFIX@,${prefix},g' ${D}${systemd_unitdir}/system/mysqld.service \ 172 sed -i -e 's,@BINDIR@,${bindir},g' -e 's,@PREFIX@,${prefix},g' ${D}${systemd_unitdir}/system/mysqld.service \
174 ${D}${systemd_unitdir}/system/install_db.service 173 ${D}${systemd_unitdir}/system/install_db.service
175 174
176 install -d ${D}${bindir} 175 install -d ${D}${bindir}
177 install -m 755 ${WORKDIR}/mysql-systemd-start ${D}${bindir} 176 install -m 755 ${UNPACKDIR}/mysql-systemd-start ${D}${bindir}
178 install -d ${D}${datadir}/doc/${PN} 177 install -d ${D}${datadir}/doc/${PN}
179 if [ -f ${D}${datadir}/doc/README ]; then 178 if [ -f ${D}${datadir}/doc/README ]; then
180 mv ${D}${datadir}/doc/README ${D}${datadir}/doc/${PN}/ 179 mv ${D}${datadir}/doc/README ${D}${datadir}/doc/${PN}/
diff --git a/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
index d76d1991b..9df4d073f 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
@@ -18,7 +18,7 @@ index 401ce30..27f382d 100644
18+++ b/configure.ac 18+++ b/configure.ac
19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros 19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
20 20
21 AC_INIT([PostgreSQL], [16.2], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/]) 21 AC_INIT([PostgreSQL], [16.3], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
22 22
23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required. 23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
24-Untested combinations of 'autoconf' and PostgreSQL versions are not 24-Untested combinations of 'autoconf' and PostgreSQL versions are not
diff --git a/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch b/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch
index fa46912ee..1f735f322 100644
--- a/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch
@@ -23,7 +23,7 @@ diff --git a/configure.ac b/configure.ac
23index fba79ee..7170f26 100644 23index fba79ee..7170f26 100644
24--- a/configure.ac 24--- a/configure.ac
25+++ b/configure.ac 25+++ b/configure.ac
26@@ -2261,7 +2261,7 @@ Use --without-tcl to disable building PL/Tcl.]) 26@@ -2297,7 +2297,7 @@ Use --without-tcl to disable building PL/Tcl.])
27 fi 27 fi
28 28
29 # check for <perl.h> 29 # check for <perl.h>
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index e29a5bef7..2dd7dd6fd 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -198,24 +198,24 @@ do_install:append() {
198 198
199 # install dirs and server init 199 # install dirs and server init
200 install -d ${D}${sysconfdir}/init.d 200 install -d ${D}${sysconfdir}/init.d
201 install -m 0755 ${WORKDIR}/${BPN}.init ${D}${sysconfdir}/init.d/${BPN}-server 201 install -m 0755 ${UNPACKDIR}/${BPN}.init ${D}${sysconfdir}/init.d/${BPN}-server
202 sed -i -e "s/^PGVERSION=.*$/PGVERSION=${PV}/g" ${D}${sysconfdir}/init.d/${BPN}-server 202 sed -i -e "s/^PGVERSION=.*$/PGVERSION=${PV}/g" ${D}${sysconfdir}/init.d/${BPN}-server
203 install -m 0755 ${WORKDIR}/${BPN}-setup ${D}${bindir}/${BPN}-setup 203 install -m 0755 ${UNPACKDIR}/${BPN}-setup ${D}${bindir}/${BPN}-setup
204 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/data 204 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/data
205 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/backups 205 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/backups
206 install -m 644 ${WORKDIR}/${BPN}-profile ${D}${localstatedir}/lib/${BPN}/.profile 206 install -m 644 ${UNPACKDIR}/${BPN}-profile ${D}${localstatedir}/lib/${BPN}/.profile
207 chown -R postgres:postgres ${D}${localstatedir}/lib/${BPN} 207 chown -R postgres:postgres ${D}${localstatedir}/lib/${BPN}
208 # multiple server config directory 208 # multiple server config directory
209 install -d -m 700 ${D}${sysconfdir}/default/${BPN} 209 install -d -m 700 ${D}${sysconfdir}/default/${BPN}
210 210
211 if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then 211 if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
212 install -d ${D}${sysconfdir}/pam.d 212 install -d ${D}${sysconfdir}/pam.d
213 install -m 644 ${WORKDIR}/postgresql.pam ${D}${sysconfdir}/pam.d/postgresql 213 install -m 644 ${UNPACKDIR}/postgresql.pam ${D}${sysconfdir}/pam.d/postgresql
214 fi 214 fi
215 215
216 # Install systemd unit files 216 # Install systemd unit files
217 install -d ${D}${systemd_unitdir}/system 217 install -d ${D}${systemd_unitdir}/system
218 install -m 0644 ${WORKDIR}/postgresql.service ${D}${systemd_unitdir}/system 218 install -m 0644 ${UNPACKDIR}/postgresql.service ${D}${systemd_unitdir}/system
219 sed -i -e 's,@BINDIR@,${bindir},g' \ 219 sed -i -e 's,@BINDIR@,${bindir},g' \
220 ${D}${systemd_unitdir}/system/postgresql.service 220 ${D}${systemd_unitdir}/system/postgresql.service
221 # Remove the build path 221 # Remove the build path
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb b/meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb
index 31f83a564..6df719cd9 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb
+++ b/meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb
@@ -11,6 +11,6 @@ SRC_URI += "\
11 file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \ 11 file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \
12" 12"
13 13
14SRC_URI[sha256sum] = "446e88294dbc2c9085ab4b7061a646fa604b4bec03521d5ea671c2e5ad9b2952" 14SRC_URI[sha256sum] = "331963d5d3dc4caf4216a049fa40b66d6bcb8c730615859411b9518764e60585"
15 15
16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it." 16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it."
diff --git a/meta-oe/recipes-dbs/soci/soci_4.0.3.bb b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
index 25d67ff8b..315f5d515 100644
--- a/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
+++ b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
@@ -3,7 +3,6 @@ HOMEPAGE = "http://soci.sourceforge.net"
3LICENSE = "BSL-1.0" 3LICENSE = "BSL-1.0"
4LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" 4LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
5SECTION = "libs" 5SECTION = "libs"
6DEPENDS = "boost"
7 6
8SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \ 7SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \
9 file://0001-Do-not-use-std-shuffle-with-clang-15.patch \ 8 file://0001-Do-not-use-std-shuffle-with-clang-15.patch \
@@ -18,20 +17,20 @@ OBASEDIR ?= "/opt/oracle"
18OINCDIR = "rdbms/public" 17OINCDIR = "rdbms/public"
19OLIBDIR = "lib" 18OLIBDIR = "lib"
20 19
21PACKAGECONFIG[sqlite3] = "-DSOCI_SQLITE3=ON,-DSOCI_SQLITE3=OFF,sqlite3," 20PACKAGECONFIG[sqlite3] = "-DWITH_SQLITE3=ON,-DWITH_SQLITE3=OFF,sqlite3,"
22PACKAGECONFIG[mysql] = "-DSOCI_MYSQL=ON,-DSOCI_MYSQL=OFF,mariadb," 21PACKAGECONFIG[mysql] = "-DWITH_MYSQL=ON,-DWITH_MYSQL=OFF,mariadb,"
23PACKAGECONFIG[postgresql] = "-DSOCI_POSTGRESQL=ON,-DSOCI_POSTGRESQL=OFF,postgresql," 22PACKAGECONFIG[postgresql] = "-DWITH_POSTGRESQL=ON,-DWITH_POSTGRESQL=OFF,postgresql,"
24PACKAGECONFIG[odbc] = "-DSOCI_ODBC=ON,-DSOCI_ODBC=OFF,," 23PACKAGECONFIG[odbc] = "-DWITH_ODBC=ON,-DWITH_ODBC=OFF,,"
25PACKAGECONFIG[empty] = "-DSOCI_EMPTY=ON,-DSOCI_EMPTY=OFF,," 24PACKAGECONFIG[empty] = "-DSOCI_EMPTY=ON,-DSOCI_EMPTY=OFF,,"
26PACKAGECONFIG[oracle] = "-DWITH_ORACLE=ON --with-oracle-include=${OINCDIR} --with-oracle-lib=${OLIBDIR},-DWITH_ORACLE=OFF,," 25PACKAGECONFIG[oracle] = "-DWITH_ORACLE=ON --with-oracle-include=${OINCDIR} --with-oracle-lib=${OLIBDIR},-DWITH_ORACLE=OFF,,"
27PACKAGECONFIG[firebird] = "-DWITH_FIREBIRD=ON,-DWITH_FIREBIRD=OFF,," 26PACKAGECONFIG[firebird] = "-DWITH_FIREBIRD=ON,-DWITH_FIREBIRD=OFF,,"
28PACKAGECONFIG[ptest] = "${TESTCONFIG},,," 27PACKAGECONFIG[boost] = "-DWITH_BOOST=ON,-DWITH_BOOST=OFF,boost"
28PACKAGECONFIG[ptest] = "${TESTCONFIG},-DSOCI_TESTS=OFF,,"
29 29
30# enable your backend by default we enable 'empty' 30# enable your backend by default we enable 'empty'
31PACKAGECONFIG ??= "empty" 31PACKAGECONFIG ??= "boost empty"
32 32
33# Take the flags added by PACKAGECONFIG and pass them to cmake. 33EXTRA_OECMAKE = "-DWITH_DB2=OFF"
34EXTRA_OECMAKE = "${EXTRA_OECONF} -DSOCI_LIBDIR=${libdir}"
35DISABLE_STATIC = "" 34DISABLE_STATIC = ""
36 35
37inherit dos2unix cmake 36inherit dos2unix cmake