summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index c1a011773..4c458bd73 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 14PKGV = "v${GITPKGVTAG}"
15 15
16PV = "git" 16PV = "git"
17PR = "r15" 17PR = "r16"
18 18
19inherit useradd pkgconfig autotools vala perlnative 19inherit useradd pkgconfig autotools vala perlnative
20 20
@@ -59,6 +59,11 @@ do_install() {
59 ln -s ${base_bindir}/systemd ${D}/init 59 ln -s ${base_bindir}/systemd ${D}/init
60} 60}
61 61
62python populate_packages_prepend (){
63 systemdlibdir = d.getVar("base_libdir", True)
64 do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)
65}
66
62PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze" 67PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze"
63 68
64USERADD_PACKAGES = "${PN}" 69USERADD_PACKAGES = "${PN}"
@@ -79,7 +84,7 @@ FILES_${PN}-vconsole-setup = "${base_libdir}/systemd/systemd-vconsole-setup \
79 84
80RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts" 85RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts"
81 86
82FILES_${PN} += " ${base_bindir}/* \ 87FILES_${PN} = " ${base_bindir}/* \
83 ${datadir}/dbus-1/services \ 88 ${datadir}/dbus-1/services \
84 ${datadir}/dbus-1/system-services \ 89 ${datadir}/dbus-1/system-services \
85 ${datadir}/polkit-1 \ 90 ${datadir}/polkit-1 \
@@ -93,6 +98,11 @@ FILES_${PN} += " ${base_bindir}/* \
93 ${bindir}/systemd* \ 98 ${bindir}/systemd* \
94 ${libdir}/tmpfiles.d/*.conf \ 99 ${libdir}/tmpfiles.d/*.conf \
95 ${libdir}/systemd \ 100 ${libdir}/systemd \
101 ${libdir}/binfmt.d \
102 ${libdir}/modules-load.d \
103 ${libdir}/sysctl.d \
104 ${localstatedir} \
105 ${libexecdir} \
96 " 106 "
97 107
98FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debug ${base_libdir}/security/.debug/" 108FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debug ${base_libdir}/security/.debug/"