summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch19
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb3
2 files changed, 21 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch b/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
new file mode 100644
index 000000000..ca10440a8
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/paper-over-mkostemp.patch
@@ -0,0 +1,19 @@
1uclibc does not have mkostemp() so we redefine it to use mkstemp()
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4
5Index: git/src/macro.h
6===================================================================
7--- git.orig/src/macro.h 2011-06-30 10:33:53.000000000 -0700
8+++ git/src/macro.h 2011-06-30 15:07:28.285270006 -0700
9@@ -27,6 +27,10 @@
10 #include <sys/uio.h>
11 #include <inttypes.h>
12
13+#ifdef __UCLIBC__
14+/* uclibc does not implement mkostemp GNU extention */
15+#define mkostemp(x,y) mkstemp(x)
16+#endif
17 #define _printf_attr_(a,b) __attribute__ ((format (printf, a, b)))
18 #define _sentinel_ __attribute__ ((sentinel))
19 #define _noreturn_ __attribute__((noreturn))
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 2a313e0f2..c750b2f7c 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
15PKGV = "v${GITPKGVTAG}" 15PKGV = "v${GITPKGVTAG}"
16 16
17PV = "git" 17PV = "git"
18PR = "r3" 18PR = "r4"
19 19
20inherit autotools vala 20inherit autotools vala
21 21
@@ -23,6 +23,7 @@ SRCREV = "8585357a0e5e9f4d56e999d7cd1a73e77ae0eb80"
23 23
24SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ 24SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
25 file://0001-systemd-disable-xml-file-stuff-and-introspection.patch \ 25 file://0001-systemd-disable-xml-file-stuff-and-introspection.patch \
26 file://paper-over-mkostemp.patch \
26 " 27 "
27 28
28S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"