summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/llvm/llvm3.inc8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm3.inc b/meta-oe/recipes-core/llvm/llvm3.inc
index 798d4a245..a5bd896c6 100644
--- a/meta-oe/recipes-core/llvm/llvm3.inc
+++ b/meta-oe/recipes-core/llvm/llvm3.inc
@@ -21,14 +21,14 @@ EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
21 21
22do_configure_prepend() { 22do_configure_prepend() {
23 # Remove RPATHs 23 # Remove RPATHs
24 sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules 24 sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' ${S}/Makefile.rules
25 25
26 # Drop "svn" suffix from version string 26 # Drop "svn" suffix from version string
27 sed -i 's/${PV}svn/${PV}/g' configure 27 sed -i 's/${PV}svn/${PV}/g' ${S}/configure
28 28
29 # Fix paths in llvm-config 29 # Fix paths in llvm-config
30 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp 30 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp
31 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp 31 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp
32 32
33 # Fails to build unless using separate directory from source 33 # Fails to build unless using separate directory from source
34 mkdir -p ${LLVM_BUILD_DIR} 34 mkdir -p ${LLVM_BUILD_DIR}