summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/usleep/usleep_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/usleep/usleep_1.0.bb')
-rw-r--r--meta-oe/recipes-core/usleep/usleep_1.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/usleep/usleep_1.0.bb b/meta-oe/recipes-core/usleep/usleep_1.0.bb
new file mode 100644
index 000000000..2ef4b7c02
--- /dev/null
+++ b/meta-oe/recipes-core/usleep/usleep_1.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A user tool to support sleeping some number of microseconds"
2SECTION = "base"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6PR = "r0"
7
8S = "${WORKDIR}"
9DEPENDS = "popt"
10
11SRC_URI = "file://usleep.c \
12 file://usleep.1 \
13 file://GPLv2.patch \
14"
15
16do_compile() {
17 ${CC} ${CFLAGS} ${LDFLAGS} usleep.c -o usleep -lpopt
18}
19
20do_install() {
21 install -d ${D}${base_bindir}
22 install -d ${D}${mandir}/man1
23
24 install -m 0755 ${WORKDIR}/usleep ${D}${base_bindir}
25 install -m 0644 ${WORKDIR}/usleep.1 ${D}${mandir}/man1
26}