summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-serialgetty.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
index 5b903a08c..5dd9e823d 100644
--- a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
@@ -26,12 +26,12 @@ def get_console(d):
26do_install() { 26do_install() {
27 if [ ! ${@get_baudrate(d)} = "" ]; then 27 if [ ! ${@get_baudrate(d)} = "" ]; then
28 sed -i -e s/\@BAUDRATE\@/${@get_baudrate(d)}/g ${WORKDIR}/serial-getty@.service 28 sed -i -e s/\@BAUDRATE\@/${@get_baudrate(d)}/g ${WORKDIR}/serial-getty@.service
29 install -d ${D}${base_libdir}/systemd/system/ 29 install -d ${D}${systemd_unitdir}/system/
30 install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/ 30 install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/
31 install ${WORKDIR}/serial-getty@.service ${D}${base_libdir}/systemd/system/ 31 install ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/
32 32
33 # enable the service 33 # enable the service
34 ln -sf ${base_libdir}/systemd/system/serial-getty@.service \ 34 ln -sf ${systemd_unitdir}/system/serial-getty@.service \
35 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(d)}.service 35 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(d)}.service
36 fi 36 fi
37} 37}
@@ -42,5 +42,5 @@ RRECOMMENDS_${PN} = ""
42RDEPENDS_${PN} = "systemd" 42RDEPENDS_${PN} = "systemd"
43 43
44# This is a machine specific file 44# This is a machine specific file
45FILES_${PN} = "${base_libdir}/systemd/system/serial-getty@.service ${sysconfdir}" 45FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
46PACKAGE_ARCH = "${MACHINE_ARCH}" 46PACKAGE_ARCH = "${MACHINE_ARCH}"