summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb')
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb18
1 files changed, 11 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
index 9ca850281..de23dcd5b 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -24,29 +24,33 @@ EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-docum
24 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ 24 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
25 " 25 "
26 26
27PACKAGECONFIG ??= "pango initrd"
28PACKAGECONFIG_append_x86 = " drm"
29PACKAGECONFIG_append_x86-64 = " drm"
30
27PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" 31PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
28PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" 32PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
29PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+" 33PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
30 34PACKAGECONFIG[initrd] = ",,,"
31PACKAGECONFIG ??= "pango"
32 35
33LOGO ??= "${datadir}/plymouth/bizcom.png" 36LOGO ??= "${datadir}/plymouth/bizcom.png"
34 37
35PACKAGECONFIG_append_x86 = " drm"
36PACKAGECONFIG_append_x86-64 = " drm"
37
38inherit autotools pkgconfig systemd 38inherit autotools pkgconfig systemd
39 39
40
41do_install_append() { 40do_install_append() {
42 install -d ${D}${systemd_unitdir}/system 41 install -d ${D}${systemd_unitdir}/system
43 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system 42 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
44 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system 43 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
45 # Remove /var/run from package as plymouth will populate it on startup 44 # Remove /var/run from package as plymouth will populate it on startup
46 rm -fr "${D}${localstatedir}/run" 45 rm -fr "${D}${localstatedir}/run"
46
47 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
48 rm -rf "${D}${libexecdir}"
49 fi
47} 50}
48 51
49PACKAGES =+ "${PN}-initrd ${PN}-set-default-theme" 52PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
53PACKAGES =+ "${PN}-set-default-theme"
50 54
51FILES_${PN}-initrd = "${libexecdir}/plymouth/*" 55FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
52FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme" 56FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"