summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/libxml/libxml++_2.37.1.bb')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.37.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
new file mode 100644
index 000000000..0ed8ee399
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "C++ wrapper for libxml library"
2DESCRIPTION = "C++ wrapper for libxml library"
3HOMEPAGE = "http://libxmlplusplus.sourceforge.net"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml%2B%2B"
5SECTION = "libs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
8
9SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}"
10SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
11 file://libxml++_ptest.patch \
12 file://run-ptest \
13"
14SRC_URI[md5sum] = "2f9372a6eba6e40206c11f558a8fbc32"
15SRC_URI[sha256sum] = "f3b183600532a92af355719210223f858857092b8b1531c7907155c59a6db39f"
16
17DEPENDS = "libxml2 glibmm"
18
19inherit autotools pkgconfig ptest
20
21do_compile_ptest() {
22 oe_runmake -C examples buildtest
23}
24
25FILES_${PN}-doc += "${datadir}/devhelp"
26FILES_${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
27
28RDEPENDS_${PN}-ptest += "make"